changes/rules needed to allow Miracast ?


Can anyone tell me whether the default firewall rule set that comes with CIS interferes with Miracast
Wi-Fi Direct P2P screen sharing ?

There are Miracast troubleshooting guides that claim that firewalls have to be modified to work
correctly with Miracast and Wi-Fi Direct P2P networks in general.

A search for ‘miracast’ in all the Comodo forums came up blank !

Thanks !

Hard to say so your best bet is to try to use Miracast with comodo and see if it works. If it fails then follow whatever guides that say how to configure software firewalls to allow it to work.

I was able to get Miracast WIDI to work with Comodo firewall only after disabling the Comodo driver in the virtual Network Adapter properties.

In Windows 10, right-click on the network icon at the bottom → Open Network and Sharing Center → Change Adapter Settings

Start connecting to Miracast and a new virtual adapter should show up… something like: Local Area Connection* 4 “DIRECT-UUCOMPNAMEFFc”
Right-click on it and go to–> Properties, and uncheck the COMODO Internet Security Firewall Driver…

and you should be all set :slight_smile:

Then you are disabling the Firewall completely. That’s not a solution. Disabling the Firewall package filter driver is something we only advice as part of testing or troubleshooting to see if the firewall package filter driver Inspect is involved.

legoled you saved my day! After an hour of trying to connect finally try’d to disable firewall, but the problem I had was I steam videos over internet so firewall could not be disabled… Luckily I found your tip (Google) and registered to this forum just to say THANK YOU!!

Concerning EricJH comment about how one completely disables the firewall by disabling the driver… Well you disable the driver for the adapter which connects Sony TV and PC only. I see no problem. If any than “you” should fix the firewall, so one can connect to the TV, because now it doesn’t even let connection in the learning mode…it doesn’t even recognize connection as such I guess.
That makes legoled his solution only available at the moment!

Heh, I made an account here just to post that solution, so I’m glad it helped someone :slight_smile:
And yah, I had the exact same issue, Learning Mode didn’t pick it up, Miracast only worked with Comodo disabled and then the WUDFHost.exe file showed up in the Comodo Window as coming through.
Since this is a virtual adapter and only used for Miracast, and only while it’s active, there’s no problem with having Comodo disabled for it, your real network adapter is still firewalled.