CFW doesn't recognize apps with short-fromat path (e.g. \progra~2\)

Bah, didn’t notice same topic here:
A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Reproduced easily every time.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: I run AMD Gaming Envolved app.
2: CFW asks for a new app access to the internet (actually, there are 3 separate processes).
3: I answer “Process as allowed app” on all requests.
4: CFW doesn’t grant the access to the app and keeps on asking again and again.
One or two sentences explaining what actually happened:
CFW didn’t recognize previously allowed app again.
One or two sentences explaining what you expected to happen:
CFW should recognize the app even with short format path.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
AMD Gaming Envolved (Raptr) Version 4.3.9 (3/25/2015) build 94313 overlay r94307.
Any other information, eg your guess at the cause, how you tried to fix it etc:
Going to settings, I see that there are three new rules with old short format file path - not more than 8 chars in path. So Program Files (x86) apperes as PROGRA~2.
I’ve tried to add manually 6 items with short path and with full path, but CFW still asks for permission and doesn’t let the app connect.
When I click file details in CFW request, I see short format path on all three files.
Exact CIS version & configuration:
CIS I use only Firewall.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Only Firewall with user defined rules.
Have you made any other changes to the default config? (egs here.):
Only turned off all modules except FW.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Have you imported a config from a previous version of CIS:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win 7 SP1 x64, UAC on, simple user account (not admin), UAC grants admin permissions on password request for admin.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a= Kaspersky Internet Security

[attachment deleted by admin]

Should be fixed in version <>. If it’s not fixed, please PM me and I will move this one back for further processing.


Yes, it’s fixed now, thank you!