CFW and Vidalia (Onion Tor) Bundle Incompability


just installed the latest Comodo Firewall (CFW) today, after installing CFW the Vidalia (Onion Tor) Bundle couldn’t start properly though I selected “trusted program” on Comodo Firewall alert window.

I tried to exit Comodo Firewall but still didn’t help.

I restarted the computer but didn’t help

I uninstalled, run CCleaner (registery cleaner) and rebooted and installed latest Vidali Bundle but it didn’t help. (CCleaner actually showed a MUI was missing in the register for the Vidalia Bundle BEFORE I uninstalled and reinstalled the Vidalia Bundle.

BTW I have used Comodo Firewall before and other Firewall programs and not a noob, something is just not working here.

Machine: AMD 64 X2, Windows XP Pro SP2 x32

Hoping for a solution before I throw out the program of my PC.


[attachment deleted by admin]

Usually with p2p technology there are need to be one or more ports open for incoming traffic. Is that also the case for Tor?

Or may be it is related to D+. Can post a screenshot of the Defense + logs? They can be found under Defense + → Common Tasks → View Defense + Events.

Nope, unless you configured Vidalia (hence Tor) to run as server (“relaying” traffic to Tor’s network).

Seems like this is the case. Usually Vidalia does not drop error message like on OP’s screenshot even if it is unable to connect. OP may have “blocked and remembered” D+ alert when Vidalia’s executable tried to call Tor’s executable.

P.S.: Running Vidalia bundle without any probs on XP SP3 x32 with CIS 3.14…587.

Hi again,

ok I made it work so I thought I would post away the “solution”.

I had already before allowed vidalia.exe and tor.exe and polipo.exe under:
Firewall (in the top space the second to the right) → Advanced (choose “advanced” from left side) → Network security

but that wasn’t enough, so I had to go to:

System Security (in the top space the third to the right) → (choose “advanced” from left side) → Computer Security Policy

where in I had to set again for the 3 above mentioned executable as “trusted programs”

(The description where I went in the CFW program is translated on the fly from Swedish to English as I have a Swedish setup so I hope I got it right when I explained in the step procedures where I went and did what)

It seems like when Vidalia is starting up it expect some things to “work” immediately which Comodo can’t cope with under the learning process for a fresh install so one must go and set up some things in order to make Vidalia work.

SS26 it might be just luck you got your work if you have already done some policy settings have the program should respond and to what, it doesn’t work from scratch with a clean install of CFW.

Thanks all!