CFW 8 => 10 update problems

I “administer” several Win7 machines - 64-bit and 32-bit - for myself and my family. I tried to update Comodo Firewall (free) from => (the latest) using the automatically downloaded program updates.

One machine appeared to have completed updating successfully, but all the others got stuck at cmdinstall.exe (82.2%). After a long time with no progress on the stuck machines, I killed ise_installer.exe. The install then completed on all but one.

At this point, you might be asking why I didn’t do the upgrades one at a time. Well … I’ve been using CFW since version 3.something and I have never before had any real problems with software upgrades. Comodo has just always worked, and with several machines to update and other things to do besides upgrading CFW, it didn’t occur to me to do them one at a time.

Upon rebooting every machine went crazy with parades of popups … objecting to Avast Antivirus, Dropbox, Logitech cameras, etc. that all ran under CFW 8. I tried restoring the [saved] CFW 8 configurations, but it made no difference. Finally I uninstalled the CFW 10 “update” from each machine, performed a new clean install, and again restored the CFW 8 configurations. At this point most of the machines worked.

All but one 32-bit machine. After killing ise_installer.exe the install immediately stuck a 2nd time at virtkiosk.exe. I could not kill virtkiosk.exe so I had to reboot. This left the machine so badly hosed that it could not reach the desktop: I got hundreds of popups related to OS services as they tried to start. I managed to reboot into safe mode and [since Win7 can’t uninstall in safe mode] disabled the CIS helper service. After that I was able to start the machine, but subsequent attempts to uninstall or reinstall failed.

Trying to uninstall the firewall failed with the message:
“COMODO Endpoint Security Endpoint Wizard ended prematurely because of an error. Your system has not been modified. To install the program at a later time, run setup wizard again. Click the Finish button to exit the setup wizard.”

Trying to reinstall failed with “can’t remove the old version”. After a few attempts, “Comodo Firewall” vanished from the Add/Remove list, but still the executables were there in the program directory, the service still in the service manager, and attempts to reinstall continued to fail.

After battling it for over an hour, I discovered a Microsoft fixit tool for problems with Add/Remove:

and after searching through the Registry to locate the program’s MSI id [for the tool], I finally managed to successfully uninstall the cursed thing.

All my machines are working now, but WTF is going on with Comodo? This fiasco cost me 3 hours when it should have taken me 15 minutes.


My machine got a black screen. I didn’t let my family and my boyfriend update theirs, I’ll do a clean install for them this weekend.

I just keep postponing for a further 4 hours.

Yet another thing: after upgrading CFW from =>, I find that despite having imported the CFW 8 configuration [FW and HIPS program rules] into CFW 10, I am having to (re)authorize or unblock many programs the 1st time they are run … annoying because lots of maintenance tasks run in the middle of the night.

This shouldn’t be happening. All the imported program rules are there, but they seem to be ignored until CFW 10 (re)sets them again.

I may go back to 8.4 … I still have the installer.