CFW 5.0 (Build 1142) crashes after update from 4.x [297]

TOPIC TITLE
Yet i have used Comodo Internet Security 4.1.150349 without any problem.
But after upgrading to Comodo Firewall 5.0.163652.1142 i have problem.
Problem in that after update it crashes rapidly.Diagnostic tool from Comodo Still says:Theris no error in your installation.


The bug/issue

  1. What you did: Updated from 4.x to CFW 5.0 (Build 1142)
  2. What actually happened or you actually saw: Crash of CFW 5.0 (Build 1142). But crash in fact is not terminate CFW 5.0 (Build 1142),it still running normally after that issuse.
  3. What you expected to happen or see: Is It must be run without crash.Right?
  4. How you tried to fix it & what happened: Tried analys logs + tried disable Comodos Sandbox.No success.
  5. Details (exact version) of any software involved with download link: Comodo Firewall 5.0.163652.1142
  6. Any other information you think may help us: http://qovluq.biz/uploads/fromcygwin.txt

Files appended

  1. Screenshots illustrating the bug: Appended

http://qovluq.biz/uploads/coodobug.png

  1. Screenshots of related event logs or the active processes list: Appended
    ---------------- LOGS FROM FIREWALL ----------------

http://qovluq.biz/uploads/logsfromfwall.rar
MD5 SUM:
2916ba1a51735107b3636fac1a3224c6 *logsfromfwall.rar

---------------- END OF LOGS FROM FIREWALL ----------------

---------------- SYSTEM AND APPLICATION EVENTLOG ----------------

http://qovluq.biz/uploads/system_andapplication_log.rar
MD5 SUM:
15efdd2ceb852b0a717acd6d7433b43a *system_andapplication_log.rar

Complete SYSTEM AND APPLICATION EVENTLOG:(see below)

http://qovluq.biz/uploads/additional_eventlog.rar
MD5 SUM:
96e151bfc03de8eb9e2e6d343dbfbf13 *additional_eventlog.rar

---------------- END OF SYSTEM AND APPLICATION EVENTLOG ----------------

  1. A CIS config report or file.Appended (see below attached)

http://qovluq.biz/uploads/configs.rar
MD5 SUM:
f275f721b1bcfd15cb304b25db6e135b *configs.rar

  1. Crash or freeze dump file:Appended (see below)

http://qovluq.biz/uploads/comodo.rar
MD5 SUM:
bae8a6be1c3e7a16afd47aabc5c16cd9 *COMODO.rar

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.163652.1142,AV database version=not applicable,Proactive config

http://qovluq.biz/uploads/x20.png

http://qovluq.biz/uploads/x21.png

  1. Whether you imported a configuration, if so from what version: Updated from 4.x to CFW 5.0 (Build 1142),nothing was imported by me.
  2. Defense+ and Sandbox OR Firewall security level: Defenseplus=Safe, Sandbox=disabled
  3. OS version, service pack, no of bits, UAC setting & account type: Windows XP,SP2,32 bit,Admin account & Restricted user account
  4. Other security and utility software running:Avira Antivir 10.0.0.567,Shadow Defender with exclusion list,Sandboxie 3.46,Winpatrol Free version(from admin rights launched).
  5. Virtual machine used (Please do NOT use Virtual box):Not applicable

Thanks for your report. Please append your dump file and make the report in the requested format as below. We’re very happy to help if you don’t understand anything in the format - just PM me!


We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

WHY WE ASK YOU TO FOLLOW THESE GUIDELINES
Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation

Mouse

Thank you very much mouse1
Using forum rules i reposted issuse.
If anything unclear please correct me.
Thanks in advance.

Cheers.

Thanks bug report - a very very clear bug report - living up to your name I see.

All I need is a CIS dump file. It tells you where to find this here.

Sent PM today.

Mouse

Pm answered by me.
08/10/2010 02:07 (GMT +04:00)

Thanks very much. Moving to verified now!

This seems to be the closest to my problem that I’ve seen in the various bug reports. So, rather than create a new one, I’ll pile on this one if that’s allowed - or I can post it as a new bug, if you’d prefer.

TOPIC TITLE
Ooops Bug window pops up and locks machine


The bug/issue

  1. What you did:
    Web server that runs Blackboard LMS (IIS and Tomcat)

  2. What actually happened or you actually saw:
    The

  3. What you expected to happen or see:
    Bug window pops up that does not lock down the machine.

  4. How you tried to fix it & what happened:
    I have reduced the Defense+ and AV settings - this seemed to slow the problem down, but did not eliminate it. I have now disabled D+ and AV, but there is no change - the problem still occurs.

  5. If its an application compatibility problem have you tried the application fixes?:
    Nothing is run on the server except the Web application (Blackboard 8.0.475, it is fully current).

  6. Details (exact version) of any application involved with download link:
    I can’t get details from the d/l link because it freezes up the machine.

  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    I haven’t been able to make it happen on demand, but it will happen within a matter of days on its own.

  8. Any other information (eg your guess regarding the cause, with reasons):
    I’m assuming there is a specific IIS or Tomcat request that is confusing Comodo, but I haven’t found it yet. None of this occurred prior to upgrade to 5.0 - 4 worked like a charm and I’m going to revert unless you say otherwise.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Same as provided by “BugReport”
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: No event for D+ since 10/15/2010, No event for Firewall since 10/18/2010
  3. A CIS config report or file. Appended
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used:
    Comodo Internet Security Premium: 5.0.163652.1142
    AV Sig Db Version: 6808

  2. a) Have you updated (without uninstall) from CIS 3 or 4: Yes - Uninstall from 3 to 4, but upgrade from 4 to 5
    b) if so, have you tried reinstalling (if not please do)?: Yes, no difference

  3. a) Have you imported a config from a previous version of CIS: Yes
    b) if so, have U tried a preset config (if not please do)?: Yes, no difference

  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. )

  5. Defense+, Sandbox, Firewall & AV security levels: D+= Disabled , Sandbox= Disabled, Firewall = Safe , AV = Disabled

  6. OS version, service pack, no of bits, UAC setting, & account type:
    Windows Server 2003, 64bit, NA, Admin

  7. Other security and utility software installed: None

  8. Virtual machine used (Please do NOT use Virtual box): VMware (running on ESX 4.1)

[attachment deleted by admin]

Hey and Welcome to the forums jvhealy

Try to re-install CF by uninstall it, clean the registies from CF with CSC (comodo system cleaner) or other and then install it again.

Regards,
Valentin

Hello Valentin,

No difference, I’m afraid. I just had the same error on one of the servers after a registry clean (using CSC) and a reinstall. This one today seemed to fire the bug up with Tomcat. It didn’t lock the machine in the sense that I could “Don’t Send” out of it and Tomcat seemed to work appropriately after that.

Any other thoughts?

Jeff

use this commando to see if you comodo has created any dumps %AllUsersProfile%\Comodo\CISDumps.

Regards,
Valentin

Nothing from today’s event, but here are all of the dump files on this box.

Jeff

[attachment deleted by admin]

I ended up having to ditch CIS 5 - the bug problem described above just kept happening despite many re-installations and system/registry cleanings. It was not a question of if it would happen, but when. Again, this is occurring on 10 different servers, so it’s a fairly representative sample of a real-world implementation.

I have reverted back to 4.1.150349.920 and all is working well again - the problem simply does not occur in previous versions of CIS.

what Windows do you use?

These are all Win2k3 64 Bit boxes.

CIS 5 will only work on XP/Vista/7 (32 or 64bit)