cfpupdat.exe Application Error

I have just installed Comodo Internet Security, moving away from Avast Internet Security.

I am getting a random error that looks like this:

I am running Windows 7 64-bit and CIS 5.10

The error does not seem to do anything bad and CIS is still functioning to what I see. It’s just an annoying error.

Hi Puremin0rez,
Try replacing the cfpupdat.exe from the repair folder.
Instructions here

Try running clean up tools for previous anti virus programs.
Uninstallers (removal tools) for common antivirus software

Thank you!

I have done the steps you have asked and I am currently not receiving the error.

The error is a little sporadic (and am not sure how to “trigger” it) so I will reply back if I get the error again.

Thanks for the quick support :slight_smile:

Ahhh. I spoke too soon…

I was sitting at the Logon Screen and came back to the error message awaiting me…

Same one as before.

Something possible happened with the install causing some form of corruption with the installation.
I would consider doing a complete uninstall re-install with a new installer.
Download here

You can find some good recommendations in Chirons post here about reinstalling and a good configuration link at the bottom of his post.

I have tried what you recommended and am still getting the issue…

Sorry that none of my suggestions have helped.
You could check to make certain no malware is present.
How to Know If Your Computer Is Infected

Other than that I will ask the other Mods to take a look.

seems to be a common error I followed these links from the avira forum. Did you change any settings in CIS?

I would say try uninstalling CIS using revo uninstaller free. Then reboot. After that try running Eusing registry cleaner. Clean and reboot. Then install CIS again and tell me if the error is still there.

Since you’re running 64 bit Revo Uninstaller Free will not be able to uninstall it.

What I would recommend, and I apologize if you have already tried this, is to first uninstall it normally. Then restart the computer. Also, make sure that there are no other security products currently installed on your computer.

Then run the cleanup tool for CIS. Once it’s done restart, then run it again and restart the computer when it’s done.

After that go to here and run the uninstaller for any security products which you have had on your computer in the past. If you installed a security product and it’s uninstaller is not in the list please let us know and we’ll try to find it.

Once you’re done running these restart the computer.

Then run a scan with Eusing Registry cleaner and remove anything it finds.

Then restart the computer. After it starts up again install CIS again. Then configure it as I recommend here. Do not change any other settings.

Then let us know if the problem emerges again.

Thank you.

Okay, I checked with MBAM, Hitman and CCE and I am 100% confident that I have no malware on my system.

I completely followed Chiron’s steps and am still getting the error.

I found out I can trigger the error by simply clicking “check for updates” from the “More” tab.

If I run the actual exe cfpupdat.exe file from the Program Files, it run’s without error. It’s only when I click check for updates from the GUI.

I have temporarily “stopped” the alerts by disabling “automatically check for program updates” so hopefully my Virus Definitions will still update while that is deselected.

try this:

Try to turn on Windows Event Logger in your system services. To do that, you can just open the start menu and type in “services”. Select “Services” with the little gear icon. When it opens, scroll down to “Windows Event Log”. If it’s stopped, try to start it.

The 0xc0000409 error may be caused by windows system files damage. The corrupted system files entries can be a real threat to the well being of your computer.

There can be many events which may have resulted in the system files errors. An incomplete installation, an incomplete uninstall, improper deletion of applications or hardware. It can also be caused if your computer is recovered from a virus or adware/spyware attack or by an improper shutdown of the computer. All the above actives may result in the deletion or corruption of the entries in the windows system files. This corrupted system file will lead to the missing and wrongly linked information and files needed for the proper working of the application.

try this open cmd and type “sfc /scannow”

I have done both and this is the result of the cmd

still get the error? did you run the avast uninstaller? What about providing a log from eusing registry cleaner for me?

I am still getting the error.

I have ran Avast Uninstall Utility linked from someone earlier in the post.

I’m not sure where to get this “log” from. I ran it like 3 times and it finds no more issues, but I do not see where it offers a log file at. Thanks!

If sfc does not work all you really have left is to ignore it or to a repair install.

I guess I’ll just ignore it then.

Will disabling “automatically check for program updates” also disable the Virus Definition updates? If that’s the case I’ll just go back to Avast I suppose. Program updates arn’t that important to me and I’ll just check every so often.

No it will not disable Database updates, these are set through Antivirus, Scanner settings.
Sorry no solution has been found.

Form what I see you found a bug.

If you have the time and energy please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Reporting of bugs is strictly moderated to make sure Comodo gets clear bug reports. So, please make sure you closely follow protocol. That way your report will certainly be seen by Comodo staff.

Original topic:

My help topic was closed and I really wanted to share with you how I fixed my issue so I will make this thread. Sorry if this is not allowed.

So it turned out that Comodo’s THEME caused the issue I was experiencing. I was desperate to try anything to fix it so I decided to go thru all the themes since I noticed the issue only happened with the GUI.

Turns out that switching Comodo’s theme to “Windows Default” 100% fixes the issue!

Every theme with “COMODO” in the name gave the same error.

What a strange bug? I wonder why my computer reacted this way?

Anyways, thanks for everyone that tried to help me and cheers for CIS!

Sorry, it seems like my original thread was not closed but I’m just unfamilar with this forum software. Sorry!