cfpres.dll Error 0x0 (V3.0.13 x32)

I saw this after bringing my laptop out of suspend mode. I have no idea what the error is about, but it
was enough to kill CFP. :cry:

I think I know now why Comodo released the final on the 20th of November - they did not have enough BETA testers ;D

Al (what happened to RC2) Adric

IBM T41 Laptop
Intel(R) Pentium(R) M processor 1700MHz
1GB Memory
Windows XP + SP2 + WUS security Fixes
SpywareTerminator 2.0.1.224
Symantec Antivirus Corporate Edition 9.0.3.1000

[attachment deleted by admin]

Same for me… Happens 2 times up to now.

i got the second error when first rebooting my computer after installation. same version and type. at least, i think that it’s the same version. when i check the version number in the file properties, it says 1.0.0.1, but i just downloaded/installed the latest v.3.

additionally, this is the same error i get if i try to uninstall.

Got that one too, same errors. I made screenshots of them, but the screens are the same. Also I got a notebook. It happend when booting up XP.

(latest version of Comodo, uninstalled 2.4 → installed v3 some days ago.)

I also had a boot problem but only on the 3rd day of use of v3. Go figure! Everything
up except CFWPro v3. I solved it for now by opening the FW manually and all is working for now. I’m running WinXP SVc PK 2 fully updated.

I suspect a conflict between Avast 4.7.1043 and have consulted both Avast and
CFW forums where the problem is documented. I like the new v3 and for now I can
deal with starting it manually if only this problem is fixed soon.
Donna

Hi,

I had the same problem and fixed it, I went in the comodo\firewall directory and noticed that there was a repair directory, when i checked what was in there i found that there was an identical copy of the file cfpres.dll, so i renamed the file cfpres.dll in the comodo\firewall to oldcfpres.dll and copied the cfpres.dll file from the repair directory to comodo\firewall directory, I rebooted and it worked !!! i rebooted a second time and it worked again and again… hope this helps.

Thumper

HI Again,

I was able to recreate the error concerning the cfpres.dll, the secret is not to double click on the comodo firewall desktop icon, instead use the icon on the task bar to call it up. When I used the desktop icon to call up the comodo firewall menu it did not come up, and the next time I restarted I got the error message again, I then re-copied the file from the repair directory into the firewall directory as per my previous post and everything was fine. If you always call up the firewall menu using the icon on the task bar you will never have a problem, but if you use the icon on the desktop you will have the error after you restart, I just deleted mine. I guess this is ok until a fix comes out for this issue.

Thumper

This bug i hate, u fix the bug and restart and the bug is comming back and the sucks,

i hope comodo fix the bug or i test i new firewall

[attachment deleted by admin]

Hmmmm, thanks thumper for the idea, the next day I reinstalled CPF 3.0 I had the same problem.

1.- A dialog window refers to an image file *.png , *.ico located in C:\Documents and Settings<User Name>\Application Data\Comodo\Firewall Pro\Data\ResFiles

2.- Then triggers the second dialog window with the cpfres.dll.

If you look closer the 2 windows has something in common the substring res

And by the way , I don’t know where to post it, but it would be an great idea to the next build that would had the 2.4 interface, I mean the colors, I find that the one the present version it’s too pale

What’s your opinion?

Hi,

I got the same errors

  1. error 0x0: failed for C:\Documents and Settings<User Name>\Application Data\Comodo\Firewall Pro\Data\ResFiles\prd_logo_24_24.ico

  2. Then comes the second error
    error: Error while extracting resources from C:\Program Files\COMODO\Firewall\cfpres.dll . Aborting application

Windows XP SP2
2 giga Ram
AMD Athlon 64 X2 Dual Core Processor 4600+
Comodo version 3.0.13.268
Avast 4.7.1074

i restarted it manually

Desmark

I get this same error every single time the computer starts up and it’s driving me close to insanity - I mean, it’s not a very useful protection scheme if it doesn’t even start up on its own. The only difference from other people is that the problem is reported with the configure_Learning_Apps.ico file.

The dreadful new interface has me teetering on the edge of not continuing to use Comodo. If this bug isn’t fixed soon (it’s been reported for 2 weeks now) it may just settle the debate about moving on.

Windows XP SP2 MCE
2 gigs Ram
AMD Athlon 64 X2 Dual Core Processor 4200+
Comodo version 3.0.13.268
Avast 4.7.1074

Hi,

I got the same msg like cfpres.dll error 0x0…

I found a workaround… It worked for me…If u were not installed the CFP (3.0.13.268) from the desktop… Try to run the setup file from the desktop…this will install the setup without any errors…

Regards,
Vicky.

(V) (B) (R) (S)

Yesterday I had to recover my PC from a backup utility (Acronis Home Edition) in that backup I has v.2.4 so I updated to version 3.0, and I had to made a lot of reboots, updating programs and finally (that’s not the case of this post I solved the problem that messed up my PC, fortunately I didn’t lose any file, the case that 3 time today I had the issued and just now copied the infamous DLL, sorry but it’s a nuisance, so I’m downloading a file, the I’ll reboot and play NFS Carbon to relax, even you have a backup utililty it’s always happens that is never update, mine was from november 14th, otherwise I’ll be a paranoic so, hopefully I had a partition of 10 GB to backup my stuffs

So I will tell you how it’s going

But I hope the isssue will be solved in the next build

Regards

MiguelAngel XP

(B) (V) (R)

The solution posted by Thumper seems to worrk fine, backup the original cpfres.dll and the copying the file from the repair folder, I updated Avast and no problem at all…

thanks for the idea Thumper

I finally gave up on Norton Internet Security after years of loyalty. Tired of the bloat, problems, and cost. Comodo came highly recommended. I have installed it on 2 XP PCs and 1 Vista PC (also have Avast Home on the machines, as well. I am having this start-up problem right off the bat on the 2 XP PCs, but no problem like this on the Vista PC (the Error 0X0 issue).

Does anyone know when a new drop of this software will be out with a fix to this issue. I love Comod so far, but this issue is annoying. Thanks for any knowledge.

Also, am I at risk by turining Defense + off.? It really annoys my system to the point where it is more work than it is help. I have disabled it, but wonder if I should turn it back on. Maybe I need to figure out how to use it with not all the distracting pop-up windows everytime I want to do something or install something. Any help?

I turned Defence+ off too, it’s annoying me to much. Already got some other programs, that keep things safe.