What is about the file cfplogdb.sdb?

I have found it by accident and it is much big and increasing. At the moment it is about 1,31GB big.
I can’t identify why it must be so big and what it is doing.
It is located in C:\ProgramData\Comodo\Firewall Pro
I’m using Win7 x64 RC, but i think that souldn’t be the point.

Need some help!

It should not be so big with default settings I guess. What are your settings under Miscellaneous → Logging → “If the file exceeds”?

that is what i have thought.

I have set the files size to 1MB and the file shall be deleted and a new log file shall be created.
I also tried to clean up all logs. but this file is still about 1,31GB big.

Can i delete it? Maybe then it would work.

And one other question: what is about the file cfplogdb.sdb-journal? What do this file?

You can try to delete it. I don’t know about the journal file.

This is a known bug, the firewall logfile keeps growing doesn’t get cleaned and or moved to the specified location, dev’s are aware of this one.

The journal file is temporary if I’m correct has something.

If your file is that size, then you must have massive logging enabled on your firewall rules is that correct ?

this massiv logging is from the D+.

I have changed some settings for CIS files. In espacially: I have enabled all protection settings. Therefor every hook, that tries to be installed under CIS files, are blocked and logged. Therefor would it be good, to have such a setting like in Firewall rules, to opt in/out logging for such events. Hope that this comes in v4.

the logging in Firewall is maximum 10 events per day.

Well, my size limit is set at 2 MB, but the actual file is 601MB! Space on my C: drive is very precious, and I want to shrink or move this file in the worst way!
XP Home
Comodo 3.13.120417.473

Even after I close Comodo, and use Task Manager to terminate the process, and delete the log file (and another copy under “Repair”), when I restart Comodo the file reappears, at the same size! >:( >:( ??? :cry: >:( >:(
Well, my delete worked after all. The apparent reappearance was an illusion caused by a search tool that was using an outdated index. The new sdb file is just 9K, which is great!

This is a bug, and it is know with the developers, but they haven’t fixed it yet :cry:

This is a very annoying bug, Comodo developers, please fix it ASAP, I can’t afford to lose this much space because of a bug, argh.

It’s fixed in version 4 but that is still a beta… I have not tested 3.14.x to see if that’s also fixed, but i have a feeling it isn’t.