CFP won't download for installion on Firefox

I used the Firefox download manager to download the newest version to my Download File that resides in My Docs. FF said it was “Done”; it’s sitting in FF’s download manager window, but it is not in my Download File. I’ve never had any trouble downloading anything before. What’s wrong?

BTW, I’m not all that computer literate, so pleeeze explain in words that FF uses in their menus or I won’t be able to follow your suggestions. I’m beginning to wonder if CFP will work on my beloved FF at all! Okay, I’ll try to be positive!! (:SAD)

Tried downloading on my FF ( - no problems. Are you using the built in download manager, or one of the add-on ones?
Check that your settings for your target folder have not been changed - it may have been downloaded to a different folder. Have you tried more than once to download? If not - give it another try, making sure that it downloads the full 9.08MB (32 bit) or 18.1MB (64 bit), once download is complete try “right clicking” on file in download manager and choosing “open containing folder”. I’ve been using CFP3 with FF no problems, although I have read that some people on these forums have had issues with FF download manager since V2.0.0.11 - possibly a bug in the new FF that only affects some users with a particular setup. From what I can remember those users managed to work around this problem by upgrading to the lastest beta release of FF V3.

Hi popcorn

Firefox 2 has had some download manager problems that affect some but not all users. Check out this thread. I had to finally go with the FF 3 Beta.