CFP v3 install error - visual c++ runtime error

CFP v3 had been working well - thanks to excellent comodo people.
win xp sp2 / avast / firefox / thunderbird - all kept up to date.

After working well for some time got error message on file submissions to comodo “visual c++ runtime library, runtime error” related to unexpected attempt to shutdown.

Tried uninstall / reinstall of CFP v3, but got “already installed” error message, however resolved this using the CFP file registry cleaner routine posted in v3 section of forum.

Install now fails with “visual c++ runtime library, runtime error message”

I updated runtime library as outlined in CFP v2 part of forum, but this didn’t resolve the problem.

Have tried removing avast and safe-mode install but still no success.

Would dearly love to get CFP v3 running again as prior to this issue was very pleased with performance.

Regret have no report files that I can find to attach.

Did you try Uninstalling CFP 3 in Safe Mode?

I suggest you do that. Also make sure the Reg+File Cleaner is on your Desktop so you can access it in Safe Mode. After Uninstalling then using the batch file, Install CFP 3 in safe mode.


3 xist

version is

have tried safe mode
safe mode
cfp 3 file reg cleaner tidy up
safe mode

but no further forward. Tried basic install as above without search or defense+ selected - no change.

error happens in both install and remove during install/uninstall of defense+ kernel, see attached screenshots. Error report is grayed out and can’t copy/paste, also error file isn’t in folder …\documents and settings\user\local settings\temp\xyz as stated in error message.

Have also tried Revo uninstall followed by Cclean and XP Repair Pro 2007 with same results and also manual instructions as per sticky for complete removal of cfp v3 using Registrar Registry Manager.

Current suspect is corrupted windows firewall, even though disabled during install / remove?? Had to uninstall / reinstall it as per How to Remove Firewall Included in Windows XP - to get it running in absence of cfp protection - seems to work but still shows error, see screenshot.

Other firewall has installed and run ok since this problem arose e.g. online armor personal v2, but would much prefer to get CFP going again!

Info is messy, but am trying to cover all bases. Hoping for good ideas before need for system restore or online armor.

[attachment deleted by admin]


Microsoft firewall is not contributing to current installation problem. Now fully functional after removal of Microsoft TCP/IP v6 driver which was running alongside normal TCP/IP.

At least one issue cleared up.

This is strange, Because I see no possible conflicts or anything!

Have you disabled any services before? Do you have any other problems on your computer apart from this one?

I will stand by. I will get further help.


As far as I can tell have no problems with PC other than CPF v3 install issue.

Reiterating, this problem 1st became apparent when trying to do file lookup (D+ running but not toolbar) which resulted in visual C++ error message. Closing error messages etc got control back after a delay but without success on lookup. All other aspects of CPF v3 appeared to be working fine.

When files waiting for lookup / submission grew to huge numbers I decided needed to do something about it, so did uninstall with Revo Uninstaller, Ccleaner and XP Repair Pro 2007 registry cleaner.

Reinstall led to “CFP v3 already installed message” so resolved that using CFP 3 file & registry cleaner batch file found in Help for v2 forum section, which enabled reinstall to start, only to fail at defense+ kernel with visual C++ error message. Also updated visual C++ files following another thread in help for v2 forum.

While checking for any issues and making sure I had windows firewall up and running I spotted problem with windows firewall, but have no view as to whether it existed before or was caused by CPF problem. The network connection settings under the firewall advanced tab was grayed out and had error message even though firewall seemed to be working. Windows firewall add / remove as described earlier fixed this problem (see screenshot).

IPv6 windows firewall driver error was red herring caused by windows TCP/IP v6 being selected in addition to normal TCP/IP in network properties - this bit at least resolved.

CFP had been installed and working well for many months with no problems and cannot recollect any major changes about the time the problem appeared, though do have hazy memory that it might have been about the time I updated Secunia and Hippo program checkers, though both have since been uninstalled just in case.

Will try and install CFP v2 and see if that goes ok, as that is before defense+ days??

Thanks for your patience.

[attachment deleted by admin]