CFP slow to Initialize (v3.0.21.329 x32)- FIXED! :o)

CFP slow to Initialize (v3.0.21.329 x32)

:THNK Slow Initialize problem began “after” I uninstalled CFP v2.3.0.19- I then ran Comprehensive Ragwing uninstall batch file, and also deleted Legacy drivers.
-clean anti-malware/anti-rootkit scan"s", (no other HIPS)
-Then ran “sfc /scannow” , to repair any corrupted Windows files (uninstalled IE7 first). Thorough file/Registry cleanup/chkdsk/JKdefrag (GUI- sys boot files too)…

  • I then did an Acronis True Image 11, full system Backup- easy to reinstall clean system & try something new!?
    ~~

Bug #1- CFP is VERY SLOW to initialize (4/10 minutes to “finally” get green check/initialized)( CFP v2.3.0.19 initialized fast))!-

Comodo Firewall Pro is still being initialized.

Please “wait” while this operation is in progress.

-This “wait” worries me, as I don’t delay long enough for CFP to initialize, and fear that I an NOT protected…!?

 
-Info:- Administrator, XP SP2 Home  v5.1 Build 2600 (fully updated)/ IE7.
-Only Active anti-malware= NOD32 v2.7, SpySweeper v5.3.2.2361, Sandboxie v3.24,  
- CFP Training mode, no other big adjustments.
-I attached 3 requested dumps/logs...

What now?  (:SAD) Confused techie???
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  :BNC FIX!-Re: CFP slow to Initialize (v3.0.21.329 x32) 
« Reply #6 on: Today at 01:27:25 PM »     

--------------------------------------------------------------------------------
 ;D Thank you for pointing me in the right direction! "Terminal Services"!...-
I had it Disabled, set it to Manual (Properties), and FAST CFP initialize now!

Did you do a complete new install or just update when you installed the latest version?

I’ve noticed that CPF3 is the last thing to load in my Systray but other than that I’ve not noticed any decrease in performance or anything.

Eric

Can you please try the following;

While the PC is booting and is in the middle of a “go-slow”, CTRL-ALT-DEL and bring up Task Manager. Click the PROCESSES tab and then sort them by CPU so you are looking at the processes taking the most resource time.

Ignoring the “System Idle Process” process, what process/es are taking the biggest chunk of CPU time during the go-slow?

Hope this helps,
Ewen :slight_smile:

Ewen: I ran the EXCELLENT Process Explorer/freeware Process Explorer - monitor running processes (see attachment), and system is at constantly 98% idle after initial startup, and CFP still not initialized?

I also tried another CFP clean reinstall, and got the same results?

:cry: Am I fully protected, or should I enable the Windows XP firewall… (v2.4 was buggy- “lots” of temp files?)?

[attachment deleted by admin]

Hi scott,

Do you have “Terminal Services” running in M$ services,msc?

If not this slows down initialization considerably.

Regards

Matty

Hi all,
This is an old bug, coming back from V.2.4 times.
You haven’t tried the advanced search function, scottls, have you?
Slow initialization occurs only when you have “Terminal Services” disabled, like Matty mentioned.
But don’t worry, I won’t recommend you to enable it – you’re fully protected, because drivers are loaded at boot time.
But you can always give it a try – attempt accessing the net with an application not listed in your policies – you’ll get a warning.

:BNC Thank you for pointing me in the right direction! Terminal Services!..-
I had it Disabled, set it to Manual (Properties), and FAST CFP initialize now!

Isn’t this a GUI bug? If it was otherwise as serious as it would seem, then one would think it’d be resolved long ago.

hi all
i doubt, that allowing service mstsc is best solution. Why i must allow service, what i need not. (:SAD)

Update to 3.0.22 - this bug is resolved