CFP pop ups not always in front [Resolved]


Something strange is happening! Until recently, all CFP pop ups remained on-top of any other windows. Over the last two days this is no longer the case, when I get a pop up it disappears behind other active windows. It is still there and I can get to see it by minimising these other open programs.

I un-installed and re-installed CFP, just in case something had been corrupted. But to no effect.

Any thoughts?
Thank you!

This is the first time I’ve seen anyone report this. I wonder if your other program(s) had some kind of ‘always on top’ option enabled, but still…

That’s new to me, too.

Two things:

What version of CFP do you have?

What was the last thing to occur on your system prior to this starting? (Windows updates, driver updates, hardware upgrades w/software installation, any other change? Something must have changed, in order for this to start up out of nowhere…)


Arkangyal experienced this back on June 27, 2006 with CPF 2.3 beta ;D

Aah, but that really doesn’t count against us, unless Roy’s using the Beta of version 2.3…

We’re still good. (:KWL)



The issue first occurred on the latest version (updated via update). I’ve un-installed and re-installed fresh, just in case, but the issue is still there.

I’m running firefox (noscript, cookiesafe), Thunderbird, AOL AVS, Prosecurity free. All of which were on my PC and active way before the problem surfaced. I have stickypassword, which is a more recent addition - but is has been on for 2/3 weeks. The “pop-under” problem has only started in the last couple of days.

Um?! :THNK

I omitted to say that the pop-up is behaving like a normal window, i.e. it is initially infront, but on clicking another window, e.g. firefox, the pop-up goes behind. It’s almost like the “always infront” option has been disabled.

Ok I see. Well, I just tested with a pop-up and clicked all over the place on other program windows, but it still had the priority with being on the foreground. Out of curiosity, what kind of alert was it? The one I tested was an unrecognized application monitored by App Mon.

It was a thunderbird trying to use firefox to connect to the internet, or something like that. I’d clicked on a link in an email.

As an unfortunate side effect of re-installing I’m getting a lot more pop ups at the moment, as CPF needs to re-learn all the stuff it “forgot” during the un-install/re-install. (:LGH)


I just tried to micmic a similar alert by connecting superantispyware out with opera and still don’t have this problem.

All your other software were installed weeks prior to this event, so I can’t attribute anything to this. No other changes/updates like from Windows/MS during these last couple of days?

Man, you’re just doggin’ me today! Here :■■■■ have a pint and cool down a bit… ;D

After all, that was a month-and-a-half ago; it’s practically the same as being new. Surely I can’t be expected to remember each and every one of my posts… My brain’s not that good, I can assure you. These days, I’m doin’ good to remember to get up in the morning.

Sorry, Roy, as you can see, the pop-under thing wasn’t resolved b4, either.

So I may get out of here with some skin intact, my suggestion is to file a ticket with Support: There may be some places they can have you look to track it down and resolve it. Something’s bound to have changed; it’s just a matter of identifying it.

I looked at some possibilities with Windows settings, but didn’t see anything relevant. If you file with Support, you might give them a link to this thread, as a reference, and be sure to keep us updated on their response to you.


PS: And I also did as soyabeaner; I created different popups with CFP and clicked all over; they stayed right on top, where they are supposed to. Sorry; wish I could’ve duplicated it.

I just wanted to demonstrate my searching power. Sorry (:SHY). No attack intended upon you. ;D. I actually thought I saw that before too, but wasn’t sure.

Roy: Maybe it’s ProSecurity. That’s a HIPS program, which some are known to cause conflict with CFP because it’s partially HIPS too.

Again, I’m not attacking any software in particular. Any suggestions from me that appear that way is purely coincidental. :smiley:

PS: Should we move this to the Help section? I didn’t thought it would end up with a ticket.

You’re right! I moved it. :wink: Now all is well with the universe.

Except that Roy’s pops are under instead of over. :cry:


I disabled Prosecurity, deleted opera from my app. rules. Opened it up and got a pop-up. Which became a pop-under when i clicked on another window… (:SAD)

So, does this mean Prosecurity is not the problem…?

btw. I’ve also got a UDP port scan from my router IP. I’ve read the other post you referred to and up-ed my scan rate to 200. ! Thanks!!!


Since I’m not familar with HIPS, I can only assume Prosecurity has its own hooks and drivers that may conflict with CFP even when disabled (kind of like another firewall). Again, don’t heed my suggestions in the literal sense. These are merely some thoughts. It would appear strange if there was a conflict between these 2 because why would it manifest only recently?

At least you’ve inadvertently received some benefit from the other thread :D.

The way to determine if indeed PS is interfering, is to remove it from startup; this may require disabling services and drivers, then rebooting. That way it is not running at all. Then force a popup from CFP and see what you get.

However, I wouldn’t tend to think that’s too blame. I would expect it more to interfere with CFP monitoring dlls, etc, rather than giving you a popup. Could happen, I just wouldn’t expect it that way.


Well, I disabled PS from start up and the pop-under issue seems to be resolved! Strange as PS and CFP lived along side each other for weeks without seeming problems… ???

Anyway, now it is back to CFP and AOL AVS. I may return to SSM, but I kind of preferred PS. Oh well. I can do without PS, but I can’t do without CFP ! (L)


Wow! I can’t believe my guess was right. Was there a recent version update from PS? Since SSM is also a HIPS, I wonder if you’ll see this issue again. 88)

The latest versions of CFP and PS, both worked OK together for a couple of weeks, no updates or changes to either program. Plus I’d not had to ‘deny’ anything on either one. Then my pop-unders occurred. Re-installing CFP didn’t work. De-installing PS did. Maybe I’ll re-install PS & see what happens, meanwhile I’ve let Prosecurity know of the issue. My PC feels kind of naked without something watching what’s going on!! Anyway, thanks for your guess! :■■■■

Remember the installation routes: Firewall first, other security software later. Besides, with CFP 3 HIPS rolling out soon, you probably won’t need PS or SSM (or whatever acronyms there are now like ■■■ ;D).