CFP messes up my LAN...

i recently installed comodo firewall pro v.3 after it was tested as one of the best freeware firewalls.
a few reboots later my lan connection was dead, showing that black ! in a yellow triangle [low connectivity or what it’s in english]… so i checked the LANs detais and found out that my pc was assigned to a completly unknown IP in subnet [which isn’t my routers subnet…].
I tried to repair it and got an error like “no connection avalible”, i quit CFP and tried it again, i rebooted my pc like 1.000 times, and it still didn’t work. after many hours i disabled the firewall protection, tried it again and it worked!
as soon as the firewall is enabled and i reconnect, my pc is assigned to that foreign IP.

so why is that?

Hi TWMuzic, welcome to the forums.

I suspect this is because your PC is trying to obtain its LAN IP from the router via DHCP & CFPs description of your LAN doesn’t include the routers IP. As a consequence DHCP is failing & your NIC is reverting to a default IP.

What is your routers LAN IP? Are there any other systems? How is your LAN defined within CFP?

first i added only my ip to the list [standard action of CFP when it recognizes a new network].
when i found out that it was CFP causing that connection errors i tried ti assigned the ip range from [which is my router] to to my lan, but that also didn’t work…

Hi TWMuzic

I think the LAN range might need to be - because of the DHCP subnet broadcast (

ok i’ll give it a try… rebooting…