CFP fails after a while on WinServer 2003

Have a Win2003 server (R2, SP2) with CFP 2.4.18.184 installed. After every reboot the system works well for a while (several hours) but eventualy CFP stops working. The task bar icon still “bubbles” all is working but looking at the CFP control panel everything is “off” and cannot be turned “on” again. Only solution is to reboot; not really the best for a server >:(. No errors in Windows or CFP logs. Any suggestions on where to start fault finding? Either that or CFP is coming off :frowning:

Regards,

Ray.

Bad form to reply to one’s own post but no reply so CFP removed. Fun and games that was too. Completely lost all network connectivity and had to re-install various TCP/IP associated drivers before the system would work again. Never again, bad product that doesn’t work reliably and doesn’t remove itself properly (:AGY).

Regards,

Ray.

Sorry no one came to your assistance, Ray. We (volunteer Moderators) try to respond to posts within 24 hours. Sometimes, however, new posts don’t show up the way they’re supposed to and/or otherwise slip through the cracks.

Your symptoms commonly occur when:

  1. It’s a 64-bit OS (not supported)
  2. Remains of previous firewall are interfering

Given your difficulties with uninstall, I’d guess that something interfered with CFP from the point your first began the installation.

As you’ve stated you won’t use the product again, I’ll go ahead and close the thread. If you are interested in trying to make a go of it (and you don’t have a 64-bit OS), just PM a Moderator (please include a link back to this thread) and we’ll reopen it and work with you to resolve any issues.

LM

LM,
Thanks for the reply. This was a brand new 32-bit installation without any previous firewall (other than Windows own). Having now got the system going to some extent, I notice I am still having trouble with the “NetBT” driver (???) and Trend Server Protect A/V. I suspect the latter and Comodo don’t agree with one another :(. For the moment I’ve re-instated the Windows FW but I suspect a complete rebuild is on the cards.

Unfortunately there aren’t many other free FWs that claim support for Windows2003. Think I’ll try PCTools next (sorry :wink: ) — unless you think the V3 beta might be worth a go? :-\ Anyone else with experience of CFP and Trend Server Protect?

All the best,

Regards,

Ray.

Ray,

The only AV I’m familiar with for causing mortal problems w/CFP is Kaspersky. I have searched for Trend Micro issues and came up with nothing pertinent. A lot of these network products have a built-in workstation firewall function, although I don’t notice anything about that in the TSP manual. They also frequently generate network traffic by their nature.

In most cases, conflicts seem to arise during installation - KAV being the notable exception. My suggestion (if you want to try CFP again) is to isolate the installation process (as well as uninstalls).
Thus, boot into SafeMode. If CFP is already gone, I’d suggest running a registry cleaner such as ccleaner or regseeker to clear out any registry junk (not that Windows ever keeps anything, lol) - be sure to use the backup feature prior to deletion!
Then reboot into SafeMode again, and reinstall CFP. Choose Automatic installation (as opposed to the Advanced/Manual setup). Reboot when finished. In TSP, be sure to give CFP’s executables (and drivers, if possible) full rein (ie, exempt from scanning/management). In CFP, do the same thing for TSP’s executables (define as a Trusted Application in Security/Tasks, Skip advanced checks and Allow invisible connects). Be sure to define the network (Security/Tasks) by creating a Zone and then using that Zone to Define a New Trusted Network.

If that still gives no joy, make sure all your drivers are up to date (especially for hardware). If you have control over TSP, you might try a SafeMode uninstall as per above for both that and CFP, then reinstall in SafeMode in reverse order (ie, CFP first, then TSP); sometimes that helps if there’s an operating conflict.

I know that’s a lot of effort, so the decision to go that route is entirely up to you. PCTools FW is not too bad, IMO (I’ve seen worse). Matousec rates it pretty well as Poor; thus it’s not as highly rated as CFP, but it’s a heck of a lot better than others!

As for v3 (beta or otherwise), it’s not compatible with the W2K family; that’s being dropped from rotation (only XP and Vista for v3). 2.4 will continue to be a supported product for that very reason, and development/improvement will begin again once v3 is completed (per Melih).

Hope that helps,

LM

Edit: I mis-remembered Matousec’s rating of PCTools FW; I have edited my previous comments.

LM,
Thanks for the constructive comments. I need to think about that as it’s a lot of effort for perhaps no benefit.

However, re: the quote above, I hope that’s a mistake :o. WinServer 2003 is the current Windows server level product - not due to be replaced until Winserver2008 comes out some time next year ;D. Essentially it is WinXP server. If Comodo are dropping support for Winserver2003 then they are dropping support for all current Windows servers. That makes any re-installation even more pointless :o. Is Comodo going to drop server support completely and only support workstations?

Regards,

Ray.

I’ll ask Melih to clarify on that, because I don’t think they’re going to a desktop-only type of scenario.

LM

PS: I did notice that TSP seems to have several buffer overrun vulnerabilities that almost guarantee exploitation. Ouch!

PPS: I had to edit my previous post regarding Matousec’s rating of PCTools; I was mistaken in my recollection of their rating for it. :frowning:

we are going to create even a stronger server version of v3…

Melih

Is this going to be free as well (:WIN) Hoping

OD

We haven’t even thought about that yet as we need to first analyse what is involved.

Melih

hi,

isnt it said v3 dont works on w2k? 2003?

Mike

Hello,

Last week I installed CFP on Windows 2k3 and found the same issue, that the taskbar program told me network monitoring was turned off and that reinstalling the program should fix the issue. However, it was still running in “Task Manager” programs. Also, if I opened up CFP and tried to turn network monitoring on, nothing would happen. And as stated, a reboot fixed it.

So today I logged in and added more firewall rules, and then a coworker who also logged in (via remote desktop) was seeing the issue, and I was not.

THEREFORE, I must conclude that the issue is with multiple user accounts accessing/modifying the program. My coworker and I were logged in at the same time, he got no response from the program, I had full functionality, and the server was still protected during this time.

Another thing to note: the updater said there was an update available (v3), so I downloaded it, rebooted, and then it said the new version was not compatible with my operating system. So I had to reinstall the older v2 and setup my firewall entries again.

Hope this helps.

Had this very same issue. On 2 seperate W2003 servers. Both use different builds, one of which is a new clean build. Have not used any firewalls previously on either box and both are 32 bit. Reboot is the only solution i have found.

Would be happy to work with someone on this issue if commodo would like to.

There are reports of conflicts which seem related to multi-user setups, with multiple users logged in. I know development team is aware of the issue; I presume they know the cause (but I have not heard). I know that now v3 has gone final, Melih has stated re/more development of v2 will continue; no specifics known on that (timeframe, extent, etc).

And yes, at the moment, v3 doesn’t work with any of the W2K family, including 2003. I believe support is planned for that in the future, but not currently available.

If you do some searches in the v2 boards for things like “multi-user” you should come up with some relevant posts. Perhaps there will be something helpful for you there. Please feel free to see what you can come up with using different strategies, and post your results (good or bad) here; it can only help to have more information on the issue.

LM