CFP.exe not loading & Missing files after recent update

I’ve been using the free version of Comodo firewall for sometime now and have never had a problem. I booted my computer today and a balloon popped up from my systray (WINDOWS XP, 32bit) stating i had an update available. so i clicked it and everything updated properly. It told me to restart my computer and i did. but thats when my problem started.

After booting up, i noticed Comodo was no longer showing up on my systray. This has happened before and I remedied it by going to my start menu and clicking on the Comodo shortcut. So I went to click the shortcut and the “missing shortcut” popped up. I went to look for the cfp.exe file and the firewall folder was now almost empty. it only had a LIST file named validation and a folder named Repair (inside the repair folder was another LIST file named validation). I thought Comodo might have loaded up wrong so i restarted my computer and I still had the same problem.

I then figured it updated improperly and i decided to just jump to a clean install.

I went through the uninstall procedure. rebooted. ran the CIS Clean up Batch file. rebooted. and installed Comodo firewall. rebooted.

Problem… not solved. I still have the exact same problem.

Windows is telling me Comodo firewall is protecting me, but on my task manager, i dont see cfp.exe running.

Please help. thanks.

i found cfp.exe in this folder C:\Program Files\COMODO\COMODO Internet Security\repair

i double click on it and i get this message:

“Error while loading resources from “C:\Program Files\COMODO\COMODO Internest Security\repair\Themes\default.set”. Aborting application.”


You can try system restore (Start > Programs > Acc > system tools > sys restore)

or; You can boot in safe mode (tap F8 while restarting) > Safe mode > Run Batch Again)

Reply back once you have done either of both


I uninstalled the firewall and ran the batch in safe mode. However i couldnt find the time in my system restore when i applied the update so i couldnt go back to it.

whats my next step? should i install the firewall now or do something else?

Yes; Run the batch in normal mode again;

(Before you do go through %programfiles%\Comodo
and Remove The Directory \Comodo Internet Security
As well Start > Run > regedit > Local Machine > System > Software > Comodo > Select and Delete > Firewall Pro (If exists if not go ahead and continue to install CIS)

Then Install the firewall in normal mode;

Hope this helps

thanks for the quick reply.

i deleted what was in the comodo folder but i could find the files on regedit

i get this far

Start > Run > regedit > Local Machine > System >

but i cant find software under system.

theres a SOFTWARE under “Local Machine” but comodo is not in there. thanks

Ok thats a good thing :slight_smile:

You should have a fresh install then

Report back :slight_smile:


Sadly I still have the same problem

but now i dont see a firewall folder in the Comodo folder (only a “Comodo Internet Security” folder)

windows still says im protected by Comodo

cfp.exe is still not in the task manager

Comodo is still not in systray

cfp.exe still located in the repair folder

in regedit i see software >ComodoGroup > CDI > 1

am i hopeless. what the heck went wrong? I hope this isnt some tactic for me to install geekbuddy lol.

i was in the brink of giving up on comodo, but i decided to give it another try.

Only i searched for an earlier version. I found Version 5.0.163652.1142

I installed it and guess what… It worked!

The funny thing is as soon as I got it up and running, that ■■■■ balloon popped up again telling me the update is available. I think I’ll pass on the update and stick with this one for a month or two. I guess im just an anomaly on this, because ive searched and no one seems to be having any problems with the new update. So crazy.

Thanks for the update; and terribly sorry that you are having issues ATM

Could you also fill out a bug report? (If you have any motivation to do so)