CFP.exe is not being started from the installation directory (???)

Hello Comodo friends,

Using Comodo Firewall I regularly get the error on system boot
CFP.exe is not being started from the installation directory. You should run it from T:\Program Files\Comodo\Firewall to make it function properly. Do you still want to continue?
Entering yes or no gives the msg “Comodo Firewall Pro does not seem to be started or installed properly”.

I never installed it on partition T and each time this error occurs it shows another partition (except C of course). After this error the Internet connectivity is down. Sometimes the CFP diagnostics can solve the problem somehow but most of the times it leaves me with no alternatives then to uninstall and reinstall CFP.

Is there anybody else experiencing this problem? I searched the forum for other threads about this problem but could not find any.
More important: is there a solution for this or can somebody give me a hint/tip?


Oh, forgot to mention: the OS is XP SP2.

Is nobody else experiencing this very annoying behavior? I can’t imagine, standard XP/SP2 and CFP with default options…

After my initial append this error occurred already 3 times. Before being able to write this msg I had to reboot 3 times (1st after Comodo said the problem was fixed - which was not true, 2nd after uninstalling Comodo and 3rd after reinstalling Comodo which lead me through all those initial popups).

I hope there is a Comodo specialist who can help me fix this problem.

I don’t think I can ask for suggestions for other firewalls in this forum…


I had this problem once, I just ran the diagnostics, it found and fixed a problem, rebooted and all is well.

When I restart my computer Cpf doesn’t start but I don’t get an error message. The cmdagent.exe is running but I don’t have the icon in systray. I updated using the patch for 13.268 but still have same issue.

I also had this problem once when I installed a couple of old IDE drives to the system. That must’ve changed the order of the harddisks or something and I got the error message about installation directory. The firewall offered to run diagnostics, did that, rebooted and all was well.

Win XP SP2
Latest Comodo Firewall version

Hello girltech

There seems to have been quite a bit of trouble with problems when updating using the patch. You may have better success with it if you download version 14.276 and do an uninstall (I like to do the uninstall in safe mode), and then a fresh install of 276 (not in safe mode). This has solved a lot of problems and hopefully it would for you.


Hi Rene

Could you update to version It may solve your problem.


it (also) happens when you add or remove drives
because CFP uses some windowsinternal device paths instead of driveletters, and these seem to change quite easily;msg114287#msg114287;msg109905#msg109905

yeah, thats really annoying if you swap drives regulary

and no, its not fixed in

got the problem too

still happening… requires reboot everytime afterwards for comodo firewall to run properly

I too have this problem, but only after making aclone of my OS and moving it to another partition. Seems there are registry entries created by comodo which hard code which partition it and other programs are installed on.
I was able to get it working by changing the registry key:
HLM\system\software\comodo\firewall pro\configurations\installpath
to match the partition i am using.

Don’t think this is a satisfactory solution, so i just re-install CPF after any cloning.
Would love to hear from the developers if this is an intentional extra level of security, or just poor installation procedure (wouldnt be the first time ive seen this)

Tried the above regedit but no luck… reboots continue…

When this happens rules are forgotten as well. Even tho they are still listed.

I now have the same rules listed many multiples of times.

Hi CaliDogg

Can you please describe your problem in a bit more detail so that we can assess it better. Let us know your OS, your computer specs, your security aplications, and any other software that could possibly conflict. Let us know as well what you have done and any changes from the default install.

We have some very good technical members in this forum and I’m sure that we can figure it out for you.


Hi John,

Is there any reason that many of the registry entries created by commodo refer to certain paths by the partition number instead of the drive letter?

For example my HLM\system\software\comodo\firewall pro\configurations\installpath entry is;

\Device\HarddiskVolume3\Program Files\Comodo\Firewall

This obviously creates nightmares when i move partitions. Comodo is the only program I have this problem with. Can you confirm if there is a reason for this, or is it a bug?

Thanks for your help

Hi legpeg

Sorry I don’t know the answer to this problem. It seems that when you cloned it and put it on a different partition something happened. The only solution that I can think of is to remove all of CFP and clean the registry real good and then reinstall. It looks as if you have already done that so hopefully someone else on the forum can jump in here and help out


I had this problem again today, the second time in the last week or so. Nothing, so far as I am aware, changed between shutting down last night and restarting this morning. I didn’t update, change or install anything yesterday and I had no problems.

One interesting thing, after running diagnostics and rebooting, D+ decided to relearn everything related to Windows System Files, so now I have duplicate entries in CSP. One set in the default Windows System Applications group and now individual entries in the All Applications area, same is true for several other applications, such as BOC and explorer.

As I don’t like this, I will reinstall CFP later today, it just seems to ignore what it’s already learnt.

Let us know your OS: XP
your computer specs: 2G processor, 1G RAM
your security aplications: none other than comodo firewall
other software that could possibly conflict: well… yea, but… no
what you have done: I swear to God I didn’t do it
and any changes from the default install: none… o.k, I’m lying but… I already messed with all dat

Thanks for your help. I’m already pretty sure that the firewall just needs to be fixed tho.

I followed the forum instructions for completely removing comodo firewall and then reinstalled. This seems to have made the problem stop bothering me for about a day now.


Well in my case the problem is caused by cloning the partition. If I install on my 1st disk/partition then the registry value HLM\system\software\comodo\firewall pro\configurations\installpath is;

\Device\HarddiskVolume1\Program Files\Comodo\Firewall.

When I clone the OS to another partition (the 3rd in this case) the registry entry obviously still remains as above yet, its now on Harddiskvolume3. So I get this error;
“CFP.exe is not being started from the installation directory. You should run it from X:\Program Files\Comodo\Firewall to make it function properly. Do you still want to continue?”
(where X is the assigned letter to the partition the OS and CFP were originally on)

Once I change the registry key to HarddiskVolume3, this error goes away, but like Toggie, D+ has to learn everything again. I’m guessing this is because of all the other registry keys pointing to Harddiskvolume1.

Obviously I caused all this by cloning, but I have heard that partitions can be reordered by the OS in certain circumstances. Maybe this is causing everyone elses problems.

If you installed CFP in the same partition/drive as the operating system then the

HLM\system\software\comodo\firewall pro\configurations\installpath

should match the partiton as found in the registry key;


Hope this makes sense and is of some use to someone.

Incidentally it doesnt happen with any other software. CFP is the only one i know of that stores the value of the partition it is installed on in the registry.

Bug still dormant since last post…