cfp.exe - Entry Point Not Found

Long-time Comodo Firewall 2.x user, very satisfied. Downloaded and installed based on experience with Comodo 2 and recommendations e.g.,

1st problem - on opening CFP_Setup_3.0.13.268_XP_Vista_x32.exe, following error occurs:
See attachment.

The error message is correct, there is no “procedure entry point” named “IsThreadDesktopComposited” in USER32.dll. Not in system32, not i386, not on XP cd. The list of entry points in USER32.dll goes from “IsServer…” to “IsWin…” in alphabetical order.

There is no “procedure entry point” named “IsThreadDesktopComposited” in USER32.dll.

After closing error message, CFP appears to install normally. However, after installing, the main CFP GUI status bar states that Comodo is initializing. This goes on for 7 minutes. Not just the first time. Every time. After restart, etc. After 7 minutes, status bar changes to “up and running.” But CFP does not seem to actually be “running”. Cfp.exe is on open process list at zero/very little cpu use, cfpagent.exe does not appear on open process list. Programs can be added to Comodo safe list, but they appear to remain blocked. Many attempts to access other Comodo features results in the same error message as at installation. Uninstall Comodo 3, clean out registry, reinstall, → same results.

Web and Forum Search for “IsThreadDesktopComposited” yield no results.

There are other issues, but this seems to be the root problem.


XP Pro, sp2, Avast AV, minimal tweaks, zero previous issues with Comodo 2

[attachment deleted by admin]

Try this:

The discussion in Darko999’s reference states, “DWMAPI.DLL” is a Vista file not being installed with IE7 under WinXP by default. That file is not present on my WinXP systems while
having IE7 installed as well." Using that info, the thread starter with a problem similar to mine reverted to IE6 and he/she said that solved the problem - Comodo 3 installed an ran fine.

But I didn’t want to go back to IE6 so searched for dwmapi.dll. Sure enough, it was in System32. Checked it out with dependencywalker, seemed pretty innocuous, so I just renamed it to disable and tried installing Comodo 3 again.

Reboot → Comodo 3 installed smoothly and is now running like a champ. The reference implies that disabling dwmapi.dll has no deleterious effects in XP. That appears to be correct. Altho I use Firefox primarily, I just played around with IE7 for a while and it seems to be running fine after disabling dwmapi.dll. I presume dwmapi.dll could be deleted, but I’ll leave it disabled for now.

I can imagine at least fifty ways that a Vista .dll could get into an XP system. Guess I could have used one of those before/after programs, but I wouldn’t have known the difference or had any concern until this Comodo 3 thing came up.

Now that I’m able to run Comodo 3, why the 6 minute “initializing” when Comodo starts up… Is Comodo functioning during that time? But I see others have posted that question and will follow those threads for news.

Thanks Darko999 for finding the reference. (:CLP) I would have been up a creek without my Comodo otherwise.