cfp.exe eats 99% CPU [NBZ]

  1. What you did: installed Comodo Firewall v5.3.174622.1216 (standalone)

  2. What actually happened or you actually saw: about 3 or 4 days into using said version, cfp.exe began to eat CPU towards 99% any time I would use firefox.

  3. What you expected to happen or see: I expected nothing to happen as I was not expecting this particular process to take charge of my processor like it did.

  4. How you tried to fix it & what happened: after closing firefox, the CPU usage would hang around 99% for about 20-30 seconds before settling back down. I then uninstalled and reinstalled CFW but that didn’t solve the problem. it seemed like it got worse and began doing it with any program or just by itself in idle time at random.

  5. If its an application compatibility problem have you tried the application fixes here?: had no issues with it prior to 5.x (using 4.x before).

  6. Details & exact version of any application (execpt CIS) involved with download link: considering the outcome of question #4, I doubt possibly dozens of links would be helpful.

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: I do not know. I upgraded from 4.x when this issue began (do not ask for specific version, I can’t remember. I do believe it may have been 4.1).

  8. Any other information (eg your guess regarding the cause, with reasons):

I have tried putting Avast and all running Comodo related processes in the Defense+ shellcode injection exclusions list but that did not help. I uninstalled both Avast and CFW, ran the proper cleaning tool for both programs, reinstalled both and updated Avast to the latest version (currently 5.1.889) a number of times before installing CFW v5.3.175888.1227 along with Avast. seemed for a while it solved my issue. but now it only occurs while using Pidgin (first application to have this issue on this firewall version) and now as of tonight, Skype (had not used the program before at all. I just installed it). I put both Skype.exe and Pidgin.exe processes in the exclusions as well but only solved the issue more or less for Pidgin. using Pidgin version 2.6.6 and Skype version 4.0.0.227.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: N/A
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: N/A
  3. A CIS config report or file. N/A
  4. Crash or freeze dump file: N/A

Your set-up

  1. CIS version, AV database version & configuration used: when the bug happened, CFW standalone v5.3.174622.1216. currently using v5.3 175888.1227.

  2. a) Have you updated (without uninstall) from CIS 3 or 4: yes
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: have tried a clean reinstall and tossing settings. uninstalled, rebooted, then ran Comodo cleaning tool in safe mode, then reinstalled.

  3. a) Have you imported a config from a previous version of CIS: I have not.
    b) if so, have U tried a standard config (without losing settings - if not please do)?:

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): I have not.

  5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe Mode, Sandbox= Enabled with standard settings when enabled, Firewall = Safe Mode, AV = not installed

  6. OS version, service pack, number of bits, UAC setting, & account type:

OS version: Windows 7 v6.1.7600 Build 7600
service pack: I assume SP1 (don’t know where/how to check if listed)
number of bits: 64(?)
UAC setting: standard
account type: administrator

  1. Other security and utility software installed: Avast 5.1, Malwarebytes’ Anti-Malware, Spybot S&D
  2. Virtual machine used (Please do NOT use Virtual box): N/A

Thank you for your bug report in the required format.

Moved to verified.

Thank you

Dennis