CFP doesn't start at XP startup [Resolved]


I have just installed CFP 2.4 and it does not start at windows XP startup.
“cmdagent” starts automatically but “cpf.exe” doesn’t.

What could be the problem?


What operating system do you have? Make/Model/version/etc…

Did you have any other active security software running when you installed it (ie, antivirus, antispyware, HIPS, registry protection, etc)?

Did you make any other changes at or around the same time as you installed the FW?


PS: Welcome to the forums!

Thanks for the welcome!

I have XP Professional with Ad-Aware Pro 1.6, NOD32 2.7 and WinPatrol installed on it.

All of them was running when I installed CFP but I did not received any message from them (however I always used to when I install something new, so it’s strange).

During the install process I did not do anything else.

Maybe should I reinstall CFP while shut the other security softwares down?
If yes, can I somehow export and then import my settings including the learnt programs list?


That was actually my next suggestion; good job! :smiley:

I have generally found it to be a good idea to turn off any active security software, especially while installing CFP, so that’s a good step to take. Please do so while you uninstall it, as well. You might want to also clean out the registry after uninstalling the FW (prior to reinstalling it), to remove any leftover entries. If you don’t want to do so manually, you can use a software like CCleaner or RegSeeker (both free) to automate the process. Just be sure to use their options to create a backup of the registry.

Also, when you reinstall CFP, be sure to choose Automatic, rather than the Advanced install mode (which will force you to do a manual configuration of the firewall and seems to cause trouble for most users).

And yes, you can create a backup of your current settings to import back in after the reinstall. Please see this thread:,2366.0.html where there is a batch file to do just that. It should tell you, but just in case… prior to running the batch file to create the backup, and prior to importing that backup back in, you will need to do two things within the FW GUI.

  1. Change the Security Level to Allow All
  2. Go to Security/Advanced/Miscellaneous, and uncheck the box “Protect own registry settings.”

Obviously, when you do this after reinstalling to import the settings back in, you will want to check the registry protection box & go back to Custom, after the import is complete.

Let me know how that goes.


I tried everything we talked about: reinstalled CFP with shut other security softwares down but it still disappears from Autorun.

Before that I used ZoneAlarm Pro: I checked regedit and found that “zlclient.exe” is still in Autorun although ZA has been completely removed.

Maybe it does not allow CFP to auto-startup? I tried to remove this zlclient entry manually (by regedit, CCleaner, etc.) but it writes itself back.

In a hungarian forum a helpful guy wrote a script for me to force CFP into Autorun and it seems to work but the entry disappeared again.

Now I am absolutely confused: maybe I should reinstall the whole XP (too much time…)

Anyway many thanks for your help so far!

Do a google for “Zone Alarm removal tool”. from memory, it is on the ZA site, but buried pretty deeply. If you just do an uninstall of ZA it WILL leave sufficient junk behind to affect future firewall installations (not just Comodo’s either).

Ewen :slight_smile:

Thanks, I will try to do that and come with the result back!


This thread,7369.msg53910.html#msg53910 has a link to a site with a ZA removal tool. Don’t think it’s by ZoneLabs; someone else is providing it. If I recall correctly, the “official” ZA removal tools has been reported to be less than 100% effective.


I added this to the FAQ exactly one week ago:

** FAQs/Threads - Read Me First **

[b]Firewall Won't Automatically Start Up[/b],2728.0.html,6515.0.html,9894.0.html

I tried this ZA removal tool (it seems very good) in safe mode, and worked - I thought!
After reboot zlclient.exe was in Autoruns and cpf.exe disappeared again >:(

Then I ran 2 different regcleaner apps and removed every ZA entries from registry; it did not help.

In Soya’s FAQ section I have just found a possibility I did not try yet: the msconfig “method”.

I will try it today evening and will return with the result: perhaps it’s my last chance before being very upset and reinstall XP :wink:

Ps: I’m angry because CPF seems very good to me and wanna use it

In that last link above, you should be able to manually added in that registry key (which should already be auto-generated by CFP upon installation). More than likely the cause is some other security program that prevents registry changes to the startup hives. And judging from your list of programs used, I’m not surprised. Trust me, reinstallation of Windows is the last thing you would want to do for something this trivial, especially when many users have experienced the same.

i have had problems installing things which make changes to the registry and ad-watch was the problem. I had to uninstall adaware/adwatch and install the new prog then reinstall adaware and adwatch (:NRD)

Looking a WinPatrol, I’d be suspicious that is part of it… check out this page: #2 item is “Automatically Disable Reocurring Startup Programs;” with that and some other little nuggets in there, it could cause problems. Especially if it has an entry in Services, which could well be running even if you shut the application down.


ZA Firewall is very particular in how it needs to be uninstalled to eliminate the TrueVector Engine from remaining and staying as a startup item after ZA is uninstalled.
Before ZA is uninstalled you have to go to the options page and Uncheck the “Start when Windows Starts” option, reboot so it’s not in startups, and then uninstall.

Otherwise the TrueVector engine does NOT uninstall and does NOT get removed from the startups, as you have recently found out.
Reinstall the exact version of ZA firewall you had installed and uninstall it this way now.


Thanks for joining the forums with such a helpful tip, Chappy! Bienvenidos! Welcome!

There’s something else for you to try, nordic… don’t reformat and reinstall the OS just yet! :smiley:


Hi All,

Got it! Finally CPF can start at XP startup and ZA has disappeared. :BNC

My latest steps were (acc. to your advices):

  • uninstalled Ad-Aware and Winpatrol
  • uninstalled CPF
  • cleared the registry by Regsupreme Pro
  • checked and removed all ZA entries by “regedit”

after a reboot:

  • installed CPF
  • reinstalled Ad-aware and Winpatrol

…and now everything is working fine! (:CLP)

Many thanks for ALL of your great advices to ALL of you! :Beer


Great news, nordic! Glad you got that working (:CLP)

If you find the issue still exists and you need the topic reopened, just PM a Moderator (please include a link) and we’ll be glad to do so.