CFP and computer LAG


I have some problems with CFP. I get LAG (computer freezes for 1-2 seconds), when I have CFP installed. First I thought it is computer, but then I got new motherboard + CPU and new graphics card. But the simptom remains. This LAG apears randomly, specialy when playing games.

But first to answer most obvious: it’s not my hardware, I replaced it with new hardware and put fresh windows installation on it. When I uninstall CFP, all goes well. Any ideas, what could cause this random LAGs ?

My configuration: AMD Athlon 3500+ Venice, 2 GB DRR RAM, Leadtek GF 6800 GT, HDD: HitachiDesktar 160 GB 7200 RMP PATA

Thanks for help,


Ok, I found the problem. Every time a packed is blocked (in my case it were nbdgram(138port) packets from my brothers computer. I added his IP to trusted in my network monitor and the problem dissapeared.

So my querstion: is it ment for computer to lag (it is noticable, when playing a game), when a comodo blocks a request (aplication or network) ?

It’s not uncommon to see a lag when there is a high volume of traffic being blocked.

This volume might come from the NetBIOS traffic (ports 137, 138), p2p applications with numerous torrents open, and so on, as these typically produce a lot of traffic. If it’s being blocked and Comodo is logging it, you can see a delay, and even increased CPU usage.

Hope that helps,


I think that part of the CPU lag is connected with the application behavior analysis. I completely solved my lag problem (resulting from mass hammering by former utorrent peers) by setting the utorrent application control rule to “block” while I play my games.

I am guessing that Comodo is in some way scanning the local destination application every single time an incoming connection attempt is made.

This is a correct guess. It’s part of the “adaptive stealthing” and SPI engine stuff. In order for an incoming connection to be accepted, there has to be an application actively running and using/listening on the port in question.

So CFP checks all these things all the time.


I should correct my previous statement since I have discovered that some lag issue still remain in spite of all that I have tried.

I’m just going to try some other firewall.
Thanks anyway.

So if I understood you right, the writing to log file makes the computer lag, not actualy the block rule itself ? What can I do with it, becouse if I have several application block rules, they will make computer lag each time, they are triggered (CPU usage shouldn’t be a problem - AMD Athlon 64 3500+ Venice). ???

You can either modify the rule so that it blocks without logging or you can make the log file itself read only.

Log Files usually at: C:\Documents and Settings\All Users.WINDOWS\Application Data\Comodo\Personal Firewall\Logs


Indeed. I discovered that read-only trick and it at least stops cpf.exe eating cpu.

** FAQs/Threads - Read Me First **:

[b]Version 2.4 - cpf.exe and High CPU[/b],6819.0.html,6933.0.html,6943.0.html

Version 2.4 - cmdagent.exe and High CPU,5499.0.html,5972.0.html,6160.0.html