CFP and Avast Web Sheild (ashwebsv.exe) [RESOLVED]

seems Avast, specifically ashwebsv.exe doesn’t play nice with CFP

most web sites refused to load with firefox or IE. some would load partially, missing CSS formatting.

under Network Security Policy, I had tried a setting of Trusted Application and Web Browser with the same results.

Turning off Avast Web Shield made for happy browsing.

I am running todays beta CFP on WinXP x64.

Yes. I have noticed the same problem and your solution works.

Otherwise CPF works great!! Definitely a superb program.

I am running on Win XP Pro x64.

I read somewhere that you change proxy in IE and firefox to 127.0.0.1:12020 and it’ll work.
Remember to change redirect port in avast web shield to 12020.

Ragwing

Yes youre correct everything works fine by just chancing from Web Shield options http forwarding or something from port 80 to port 12020

:smiley:

hmmm, changing that setting in Avast works, without touching the proxy settings of IE/Firefox… interestingly odd

(:TNG) :THNK :■■■■
At least all the pages load properly now :BNC (:CLP)

Yes! it works without having to meddle with the proxy setting! and doesn’t matter which port number it is set to, as long as it is not 80! Thanks!

How do you change the Avast Web Shield port settings? I can’t find it. Do you mean the update connection settings?

Never mind-- I found it. It’s in On-Access Protection Control after right-clicking the Avast taskbar icon.

I believe these are the right configurations for aVast & IE…

[attachment deleted by admin]

I believe these are the right configurations for aVast & FF…

[attachment deleted by admin]

These seem to work ok, thanks :slight_smile:

NEEDS TO BE APPLIED TO THUNDERBIRD ALSO

I have learned that using Avast that I had to set 127.0.0.1:12080 proxy to ALL these to work correctly:

-Firefox
-IE
-Thunderbird
-WinAmp
-Last.Fm

I dont know whats going on…

XP64

Whats going on is that CFP somehow breaks redirection of HTTP traffic, that Avast WebShield normally does. Strange is, that redirection of POP3/SMTP/IMAP/NNTP traffic (done by another process of Avast) works fine.

Sorry for an perhaps a bad question, but where do you set this, in IE or Avast. If Avast where.
Wondering becouse i’ve got the same problem, had to disable the web shield in Avast.

Best regards
Pims