CFP 3 shows up in Security Center after uninstall

i just got rid of comodo firewall and its still showing that i have it install and running under security center. i have vista premium. i have third party uninstaller that removes everything, well at least i thought even from the regedit. but from what i read there is another directory in the registry that keys might be left in. security center registry files. im not exactly show how to find it. any suggestions


  1. Open start menu and click Run and write cmd.
  2. In the cmd window, write NET STOP WINMGMT /Y.
  3. Now write cd "%windir%\system32\wbem" and then RD /S /Q “Repository”.
  4. Last of all, write NET START WINMGMT /Y.
  5. Close the cmd window and security center should no longer report it.

That should solve your problem.


is this the same for an 64-bit Vista Home Premium?

I’ve had a problem with Comodo showing a black screen after logging in…

I used Safe Mode to remove Comodo (as that was the last app I installed), and my computer is up and running (on vista fire(hole)wall), and showing that both firewalls are up and running, but I can’t find any more references to Comodo anywhere on my computer…

More usefull information: I’m using multiple user accounts on my pc, maybe I missed doing something with setting up Comodo?

bump? Sorry to be this rude, but I really need an answer to this question… (:SHY)

Sorry that no one have answered your question. To answer your question; yes it’s the same method, but you’ll need to run Command Prompt with administrative rights.


Another explanation for correcting Security Center.

will that ‘fix’ posted by Ragwing Reborn work with windows xp pro?

Hmmm - so when CFP 3 is disabled by malware security center will show that cfp is still active (assuming that security center isn’t affected by the malware :D) - I think you should fix thix behaviour asap :slight_smile:

Comodo cannot be disabled by malware. Comodo just got voted #1 by Matousec. This behavior about security center happened to me with Online Armor and Threatfire.

so how did manage to persuade your PC that Online armor had been uninstalled?

Older versions of Online Armor this was happening to. They fixed it. Its no big deal. Look at the link posted.

excellent - I trust that method works for xp pro (as the article seemed to be focused on vista users)

Every software security product can be disabled by malware ^^. You just have to find a way how to do that :smiley:

The security-vendor’s part is to patch it’s software if a new way of disabling their product has been found :wink:



well I’ve just had a look at the WMI & can not see how to temporarily inactivate it prior to deleting the relevant folder (which I have found). Do I need to do this in safe mode plus administrator?

You need to stop the WMI service. Then delete the repository folder and reboot. Go to run and type “services.msc” then find the WMI service.Windows Management Instrumentation

Comodo can be disabled if the malware installs a driver. That’s the reason for why IceSword is able to terminate CFP, because it installs a driver to do the job. But if you use common sense, and doesn’t allow everything to install drivers, you’ll be safe.

No, you’ll only need to be on an administrator account.

Just tried this (twice) and WSC still reports Virus protection not found. Any other ideas?