CFP 3 doesnot allow Vista to get a dynamic IP via DHCP


I’ve installed CFP 3 on a Vista machine.
But CFP does not allow Vista to get a dynamic IP via DHCP.
How do I configure CFP 3 to do this?


Assuming that your PC gets its IP address allocated from your router, you will need to create a zone that encompasses the address of your router and the address within its address allocation pool. you will then need to create two rules, one in and one out, to and from the zone to allow LAN type traffic.

If you have a look at

read through and find the PDF attachment, which steps you through how to do this (please note that you may have to use different IP addresses to those shown in the PDF).

I’m aware that there are other ways to do this in CFP V3, but doing it manually will, hopefully, give a greater insight into how the policies are constructed and a greater understanding in what they do.

Hope this helps,
Ewen :slight_smile:

Thanks for the reply Ewen. Appreciate it.

My connection is setup such that I directly get a legal IP in the 123.235.y.z range from the DHCP server at the ISP end. There is no NATing involved. Also the DHCP and DNS servers are within a different network ( 220.225.x.y.) range. I don’t have a personal router.

You sugested that there were other ways in Comodo too. Could you share some of them with me?

I use CFP 2.4 on another PC and getting an IP address doesnot pose a challenge. How could I achieve the same in CFP 3.0?


Does the CFP 2.4 PC connect using the same method as your CFP V3?

Yes Ewen it does. I should have mentioned that earlier :slight_smile: .

Actually it’s the same PC configured with a dual boot 1) XP and 2) Vista.


I was simply referring to the StealthWizard which will create rules similar in intent to the manually created rules in my doc.

Can you check if your CFP 2.4 install has the option to block all comms during the boot process DISABLED?

Ewen :slight_smile:

Hi Ewen,

Yes the option is disabled.
There are times when the IP lease times are as low as 5 minutes. So I have allowed SVCHOST.exe executable BOOTP ( UDP 67 and 68 ) access to the Internet and it works.

CFP does make things a bit more difficult. I’ve tried doing the same for CFP 3 bit it doesnot work. This could be because VISTA may not use the SVCHOST.exe route any more.


I think it (svchost.exe) still does, but I’ve got a sneaking suspicion that CFP V3 blocks all traffic (incl. DHCP) during boot and I can’t find a switch to disable this. I’ll dig further

Ewen :slight_smile:


Can you have a look at firewall logs and tell us what it is blocking?

Firewall->Common Tasks->View Firewall Events.

Also, if you disable the firewall, does it work?


Hi Ewen and Egemen,

Even if I disabled the firewall it still didn’t get a new IP address.

I tried to reinstall CFP 3 on my Vista partition and it worked without any tweaks. The only difference in this times install is that I first installed it without the Defense+ component and then enabled it once I confirmed that CFP was not misbehaving. Guess that, for some reason, it wasn’t installed correctly the first time around.

I also confirm via the CFP logs that it’s the svchost.exe that gets the dynamic IP address in Vista.

Thank you for your prompt assistance.