CFP 3 Blocks Firefox Downloads

Comodo is blocking FF3 from downloading anything. It downloads, but the file doesn’t exist. I’m installing it on a friend’s PC, a brand new HP laptop, and the only other thing installed is AVG 8 Free.

I selected “Web Browser” as the program type.

Try putting Firefox as a Trusted Application.

When you say the file doesn’t exist, where have you told FF3 to store it under tools/options/main? Do you get a normal download dialog and progress display, and no file or just a filename or ? ANything in the firewall log?

Are you sure your looking in the right place for the download.In FF3 look in “Tools”/Options/Main does it say under downloads to save to desktop.

Do you get a pop up when trying to dowload something?Not used AVG 8,does it have a web shield.Try putting Defence+ in “Training” mode then download something from a reputable source.MAKE sure you put it back to Clean/Safe mode after.


Depending on several factors, FF3 will remove downloaded files after downloading then based on the setting of the windows internet options miscellaneous option “Launching applications and unsafe files”. This is related to FF3 calling the install anti-virus to virus scan certain files.

This thread will give you more information of FF3:

Done already.

Desktop. My friend is using Vista, so I have selected it to go to the Downloads folder as well, but no dice.

I get the Download Manager, and it downloads the file, but when I try to open it, it doesn’t exist. I right click, and the “Go to folder” and “Open” options are greyed out.

No, I didn’t enable it. AVG 8 didn’t even install correctly, it didn’t run. So that’s not the problem.

I am currently reinstalling Comodo, I’ll do that next.

Not Applicable.

Oh and don’t be afraid to use technobabble, I’m not as hopeless as your mom with a PC, nor am I new to fixing tech problems.

Since he is using Vista, you can try a couple of things:

  1. Turn off UAC in Control Panel
  2. Right click the FF shortcut and select “run as an administrator”
    You may not have permissions adequate to access the downloaded file.

[quote author=sded link=topic=24215.msg172150#msg172150 date=1214007540]

  1. Turn off UAC in Control Panel[quote]Already done.

No effect.

Doubt it. I (she) is an admin.

I had the same problem (and, upsettingly, “Web Browser” doesn’t come up as a type I can choose!) and tried everything I could find online … I finally ended up Googling the full text of the FF3 error (I also couldn’t download from IE7, by the way), and came up with an answer that worked - I had to go into the Internet Options, chose Custom Level, then set ‘Launching Applications and Unsafe Files’ (under ‘Miscellaneous’) to ‘Prompt’.

Worked like a charm.

The absolutely bizarre thing, though, is that I was not having this problem at all before Comodo was installed - obviously, or I would never have been able to download the installation executable.

Don’t get it, but it works, and I’m happy!