CFP 3.0 and IBM Lotus Symphony: an annoying issue.

I tell you what happened:

I’ve been in touch since somewhere in the end of December 2007 with the team of IBM China, responsible for the development of IBM new and free Office Suite: Lotus Symphony. The release in question was a beta 3, supposed stable. No reason it wouldn’t be as beta 1 and 2 were already stable. My issue was that every time I tried to install it, for some unknown reason the process was aborted with an error message: “partial install” occurred. I went through everything from deactivating all security software, including CFP 3, AVAST, Windows Defender…to changing the temporary folder location, deleting all files and registry entries left after failed Lotus Symphony installs…and nothing changed, no way to install it. And the development team, although some other users (who didn’t say if they used CFP) had the same issue, just couldn’t reproduce the issue (on Windows XP).

And this morning, I got another mail from IBM China so I thought why not try that: instead of just deactivating CFP I will uninstall it completely, reboot, and see what that does. And guess what: no problem anymore, Lotus Symphony would install like a breeze. Which means in other words that even deactivated, Def+ or the firewall or both still have some impact on the system, even after reboot.

Last thing is I felt obliged to send a new mail to IBM China to tell them I was sorry about all the trouble and the time they spent investigating and trying to reproduce the issue, when the fault was somewhere else.

(Wanted to add that as I successfully installed Lotus Symphony, with CFP not present in the system, I noticed a prompt from Windows Firewall to unblock a connection from Lotus Expeditor. Windows firewall, as you know, prompts to unblock without blocking anything by default, where CFP fortunately blocks until permission is granted. Could have been that blocking the install with CFP present (but inactive), but I never found anything in the logs of CFP when the Lotus installs failed.

You know sometimes, I wouldn’t say Comodo rocks that much… (:WIN), but hey, now that Lotus Symphony is well installed on my PC, I’ve already reinstalled CFP :SMLR

Guess what?

I have been able to install Lotus Symphony with CFP3 active. Admittedly it was beta 2, not 3, but all I did was to allow the firewall to go into installation mode, but I left in that mode until 1) the install had completely finished and 2) I had opened the app and opened a blank document.

As soon as possible, I’ll download beta3 and try the above steps and post back her.

Ewen :slight_smile:

Ewen, I also had no problem with betas one and two of Lotus Symphony with CFP installed and active, and Def+ in install mode. And I’d like to see your results with LS beta 3.

Hmmm … I got the same result as you with Beta3. I’ll retry with some of the Defense+ settings disabled, just to make certain, but I would have expected to get an alert, though.

I’ll repost the results here.

Ewen :slight_smile:

thanks Ewen, I appreciate that you’re testing that.
(whether you decide not to keep or to reinstall Lotus Symphony, be aware that it leaves tens of registry entries unclean, easy to find and delete with CCleaner, I personally got rid of them before each new install; and there’s also a folder with an msi file in your user’s profile\application data, better to delete it before reinstalling)

OK it’s been almost three weeks since I submitted this bug and still not a word from the dev team on it. I come back to this thread today because IBM just released Lotus Symphony beta 4. Same problem as with beta 3: installation aborted. And it’s always the same file that refuses to install when CFP is installed. A file in the Lotus Symphony plugins called:

and again, switching to install mode or completely deactivating CFP and rebooting didn’t solve the issue. I had to uninstall it completely to get a successful install of Lotus Symphony. That said it would be nice if the bug was resolved. May be the IBM file has a problem, at least with CFP. And Lotus Symphony is likely to replace OpenOffice on many computers in a near future.