CFP does not play with Java (arduino)


I had v2 of CF, and upgraded to CFP on XP pro SP 2

I have an application called Ardunio - for controlling a chip-board via USB. To do so it compiles a program and sends it via COM port.

Arduino is a Java app. It does not get installed, and runs from a folder of its own.

Previously, with v2 of CF, I had no problems.

Now I have installed CFP3, I get a message from the Arduino app, stating

C:\Anthony\Software\arduino-0011-win\arduino-0011\hardware/tools/avr/bin/avr-ar: unable to rename ‘C:\Documents and Settings\Anthony\Desktop\attempt3\applet\core.a’ reason: Permission denied

I can only assume that this is because the Defense+ is preventing it from being renamed.

I have added the Arduino application as a “trusted” application, the Java.exe that is associated with Arduino ( [%arduino_install_folder%/java/din/javaw.exe) as a “trusted” application, and also C:\windows\system32\java.exe (“trusted” application)

I have added the entire folder C:\Anthony\Software\arduino-0011-win to “my safe files”

I continued to receive “permission denied” messages.

I then set both the Firewall and Defense+ to “disabled” and rebooted. Still same error.

I then uninstalled CFP.

I could then run the Arduino app with no problems.

I then re-installed CFP with all defaults - but chose NOT to install the Defense + part.

However, on reboot, Defense + is active and I cannot run the Arduino app without the error message.

Therefore: can I have advice on how to set applications that run on a java platform to be allowed in Defense+, or, how do I disable Defense+ entirely.

Dont add files to My Own Safe Files. If something git blocked you must have blocked it. Go to D+\Advanced\Computer Security Policy and look the the list of programs to see what you blocked. If you don’t see it then click add and add your program there. I never use my own safe files.


I’ve removed all files from the “my safe files”

The applications related to Arduino are listed in the Computer Security Policy as “Custom Policy” - none are blocked.

I have previously set all of these to “trusted” with no luck.

Defense + in any case is set to “disabled”, an dI cannot use the Arduino app.

Is there anyway to complete;y disable Defense + ?

if not, I’m afraid I am going to have to revert to version 2

Have you tried putting D+ in training mode then running your program. Yes you can disable D+. Look at the bottom right where you can change D+ from Safe Mode to Clean PC mode etc. D+ is the HIPS protection in Comodo and its a good idea to use it. Try training mode for a couple of days.

Well, as I say, even with D+ disabled, Arduino cannot run, so i guess it is a software conflict rather than a setting in CFP

I’ll try a few more config options but i suspect I’ll have to revert to vesrion 2

You dont have to go back to version 2.4. Did you try putting the firewall and D+ in training mode?

I have tried with-

Firewall on safe mode /
D+ on

  • Safe,
  • Disabled and
  • Deactivated Permanently,

with no luck.

Firewall on Training /
D+ on

  • Training and
  • Disabled,

with no luck.

Firewall Disabled /
D+ on

  • Training and
  • Disabled,

with no luck.

I do not even receive a notification to tell me that an application is trying to do anything.

I dont think it is related to the firewall, though- seems far more likely to be a D+ problem.

Did you try manually adding your programs to D+ into the right area. Training mode should work no problem unless you blocked something.

I have tried that - and this is now with a clean re-install, so there are no apps that might have been blocked by mistake.

Thanks for your help, but I am going to go back to version 2; I’ll wait for a couple of updates to 3 and/or teh arduino software before I re-try.

Version 3.0 has been around since Nov 07 and has been through several changes since.

Well, uninstalled, re-installed 2.4, and can use the Arduino software.

Interestingly, it asked for permission for java to connect.

I’ll wait and see if a new version of either Arduino, Java or CFP will work. Till then…2.4 is still great software, better than anything else I’ve tried.

Listen Java and Comodo 3.0 work fine. I use Java on my pc. Of course Java askes to connect cause its looking for updates.

If you are gonna go back to just a firewall why not just use CFP3 without D+? and with leak protection? Since it is still updated and 2.4 will not be updated any more.