CFP 3.0.23.364 conflict with ThinkVantage Client Secutiry Solution

I installed the CFP 3.0.23.364 in my laptop (Lenovo ThinkPad) and after install/restart, I got the error msg from Client Secutiry Solution.

there was a problem connecting to a critical service. it is possible that anti-virus or firewall software is blocking the connection. also, check to make sure that the tpm device is installed and enabled

now, I downgrade the CFP to 3.0.22.349 and I didn’t have any problem from CFP.

If you any more information please let me khow.

ps. I used ThinkVantage Client Secutiry Solution 7.00.00.22.00

Hi Ford AntiTrust, welcome to the forums.

How did you install CFP 3.0.23.364? Did you use a System Restore to downgrade to CFP 3.0.22.349? Thanks.

I updated the CFP from updater (it notified to me this morning) and I downgraded by uninstall new version and install old version again. In this case I’m not sure in this error (from the user error or updater error). I tried install new version by download 3.0.23.364 full version from comodo.com again, I got the error msg again.

I assume you uninstalled/downgraded CFP after each error? I ask, since what CFPs Log said (if anything) would probably be informative. However, it is very odd that 22.349 should not block this, whilst 23.364 does block it. I assume you have rules in place to cater for ThinkVantage Client Security Solution currently (in 22.349)?

I assume you uninstalled/downgraded CFP after each error?
- Yes
I ask, since what CFPs Log said (if anything) would probably be informative. However, it is very odd that 22.349 should not block this, whilst 23.364 does block it. I assume you have rules in place to cater for ThinkVantage Client Security Solution currently (in 22.349)?
- I didn't see informations in CFP's log or Windows XP SP3's Event Viewer.

More information.
I founded CFP 3.0.23.364 block “ThinkVantage Client Secutiry Solution” accesses to TPM embeded security chip on my thinkpad laptop. I tested by “Unlock security ship” and “Change Security chip status” in the Client Secutiry Solution. I didn’t unlock on change status on the security chip after install the CFP 3.0.23.364 but I downgrade the CFP to CFP 3.0.22.349 that work fined.

I have the same problem on a T61 with XP and version 3.0.25.378 after a Comodo proposed update. The message disappears if I stop Comodo Firewall. Should I downgrade ?

:o(

Downgrading works.

Comodo is really dropping the ball on these releases. And they have no reply or solution.

I have CFP installed on my DELL Latitude D830 since January ( I have TPM with EMBASSY® Trust Suite
Dell Edition, http://www.wave.com/products/ets_dell.asp).

I never had any problem until the new update this week (CFP version 3.0.25.378) it blocks the access to the security chip. The solution I have at this time is just disable the firewall (Defense + Security is ok, I can leave it on) when I need to access the files that protected by this TPM. The earlier versions work just fine with this TPM though. I think I can just wait for the new update

:■■■■

First of all: thanks for a great product!

I just want to say I have a T60, with a fresh install of XP and ThinkVantage utilities. Windows XP SP3 has been applied and I installed CFP and BOClean. After installing CFP, I begun getting the cssauth.exe error message:

Window title: Client Security Solution
Message: The instance of cssauth.exe cannot start because of an initialization error.

If this is, as suggested above, because CFP blocking the embedded security chip access from that application, I would like to know if something is being done about it, or if it is in Comodo’s to do’s, at least.

I use a T60 because of its security features. The same goes for Comodo Firewall Pro. I am sure Comodo would like to see its software work well with this line of fine notebooks, which have a long track record of paying attention to quality, functionality, durability and, above all, security.

Please, give us some feedback.

I am using T60P with XP and got the totally same issue today.

same issue on a T60p with XP Pro, might have to do with the transition process of migrating from ibm support sites to lenovo.com, it really got quite bad lately.

I just turned on a brand new T61, Uninstalled the Norton Security Suite, rebooted and then installed CFP. I have not yet enabled the TPM security chip at all. Now, when I boot, there is a message that access to the TPM is blocked “probably by a firewall”.
Looking for a solution, because I do want to use the TPM chip.
Thank you.

You can try this to see it if fixes your particular problem. It may not work in every instance as many folks are having Thinkpad CSS conflicts w/ Comodo CFP. Give it a try - if it works, GREAT! If it doesn’t, the developers are aware of multiple issues and are looking into the problem that seems to be unique to Thinkpads w/ CSS installed (TPM chip). See windows\system32\config for more info on the various issue similar to these. Sorry - the link for windows/sys32/config is https://forums.comodo.com/help_for_v3/windowssystem32config-t25931.0.html

Regards,
God Bless (:AGL)

https://forums.comodo.com/help_for_v3/compatibility_issues_with_lenovo_ibm_thinkpad-t17706.0.html;msg155040
Re: Compatibility Issues with Lenovo (IBM) ThinkPad
« Reply #23 on: June 12, 2008, 10:13:16 AM »


Hope this would help those who are suffering from “checking security chip status” endless loop.

Two days ago I came across this problem on my T43 laptop (Win XP SP3 with latest updates of Lenovo software… or I thought so). I’ve been using Comodo since v2 on the same machine and when the problem happened I had the latest version installed (3.0.25.378) for a week or so (I’ve always upgraded though the internal Comodo updater).

The cause of the problem in my case was that I “removed” all listings of Lenovo software in Comodo’s safe list which I had since day one for testing purposes (something I regretted later). Then I locked the computer Ctrl+Alt+Del >> Lock Computer. After that I couldn’t log back on. Restarting gave the “security chip” problem. I tried disabling the security chip from BIOS settings and everything else related to Lenovo security but nothing solved the problem. I uninstalled the firewall after log on in “safe mode” and was able to log back on. Installing the latest version of the firewall from a fresh installer caused the same problem to reappear after restarting. The same problem persisted even when I installed earlier versions of the firewall as mentioned in earlier posts.

THE SOLUTION
Apparently, the IBM System Update application (which installs the latest IBM software and drivers) was not updating the “Client Security Solution” whenever a new version was available. The old version of this software is the cause of the problem in my case as it was conflicting with newer versions of Comodo. The newer version of Lenovo’s “Client Security Solution” was incompatible with the IBM’s “Rescue and Recovery” software (also an IBM software). This is how I solved the problem:

1- From Control Panel>>Add/Remove Programs:
a. Uninstall IBM’s “Rescue and Recovery”.
b. Uninstall whatever version from IBM’s “Client Security Solution”.
2- Download the latest version of IBM “Client Security Solution” 8.1 from this IBM url: http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-69733
3- Restarted and everything was working fine.
4- I installed the latest version of Comodo (3.0.25.378) and voila… everything is working smoothly. I also witnessed considerable speed-up in Windows log on process.