CFP X32 does not remember rules for Firefox


Comodo Firewall Pro aks every time I start Firefox if I want to allow Forefox to go onto the web. If I check ‘Remember my answer’, the popup comes back and back again, so I cannot go onto the internet. However, if I uncheck ‘remember my answer’, Firefox is allowed to send information to internet.
However, the next I start Firefox, this behavior starts over and over again (because it is not remembered, I think).
I use Firefox The trouble started after 1) updating from Comodo 3.0.13 to 3.0.16, or 2) after updating Firefox to from I don’t know (maybe I did this at the same time).

Can someone help me? Thanks!


I think you have the same issue as described in this post:;msg132240#msg132240
No official answer from developers so far…

Please uninstall CFP and install it again using a 3.0.16 full installer.

BTW please refer to the bugreport board stickied topics to read about bureporting guidelines.

Thanks for your understanding,

1. CPU (32 bit or 64 bit)
Athlon 64 3000+, running 32-bit Windows.
2. Operating System information (including Service Pack Version)
Windows XP SP2 Dutch
3. Actively-running security and utility applications
Grisoft AVG Free
4. Specific symptoms of the bug, and steps you can take to reproduce it.
Every time I start Firefox, CPF asks me to allow it or not. Checking the box ‘remember’ causes CPF to ask me again. Unchecking that box allows Forefox to connect to the internet, until it is started again.
5. Specific steps you have taken to try to resolve it.
I exported my settings, uninstalled CPF, installed CPF and imported my settings. The first reboot, CPF didn’t asked me about Firefox and it seems ok. However, after a reboot, CPF asks again about FF when I start it.
6. Brief description of your Defense+ and Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+
Firewall: Train with safe
Defense+: Clean PC
In the advanced section, I added some rules for allowing P2P (i.e. uTorrent and eMule) to connect to the internet
7. If you pc reboots or you have a BSOD post in BSODs: Please add your minidump files here
I don’t have BSODs.

Version of CPF: I upgraded to this version from 3.0.13 by exporting settings, completely uninstalling that version, installing 3.0.16 and importing settings. The problem did not exists in version 3.0.13.

Well I asked you to use a full installer to see if there was any issue with the two step update proces (old version plus patch)

I’ll not ask you to install cfp again but please use the configuration manager to activate the COMODO - Network Security policy (you can also find it in CFP install folder)
and then enable D+.

Using a default untrained ruleset will prove that there is no issue related to the old ruleset.

I didn’t understand you tried to say this to me (there didn’t existed a 3.0.13 → 3.0.16 patch!), now I do. I updated (using the built-in update function) to 3.0.17, started with a new rule set, and the problem is over now. Thanks for your support.

My bad I failed to read correctlly the step you took to update to 3.0.16 :stuck_out_tongue:

Glad you solved this issue.
I’m going to move this topic to the Help board.

The problem is back again… I don’t know why, yesterday I also rebooted my computer. However, this morning I had to allow Firefox again to connect…

I guess this is a configuration issue.

The only test to address this is to use a blank ruleset and then export your cfp configuration until this issue appears again.

checking the letest two configs could be enough to find what is going on.

Ok, I agree to you. But how should I be able to find out what’s going wrong? The problem comes up if I start FF, and I don’t do that a lot of times per day (I keep it open).

We defenitely need some before/after configuration or we won’t be able to get any clue.

I guess that raising the number of FF run/quit per session could help.

Ok, I’ll see what I can do, but I do not have the time for it now. I’ll report back if I got new information.

I have the same problem with last versions of Comodo (last version without this problem is But not in Firefox only - in some other programs too (Opera, SecureCRT etc.). The problem is very strange - if I check “remember my answer”, it does not remember and show me popups. But when I uncheck it - all is fine. This behaviour is as in clear installation (with previous uninstallation using complex instructions from this forum) with default rules as in imported configuration. I could not update to the next versions because of this problem. works fine. So seems that you introduced a bug from 3.0.15 version

I’ll move this in the bugreport board again meanwhile please look at HOW TO SUBMIT BUGREPORTS in order to post other useful infos

The new CPF 3.0.18 solved it for me, after doing a clean CPF install!

wait just to be on the safe side please backup your cfp configuration at least once each reboot using different files.
Lat time this issue reappeared after a while…

I just started TVants (which is remembered in 8.3 file format). I click ‘allow and remember’ but the popup comes back and back. If I do not tick remember, it is okay.

(The 8.3 file format is as I described here.) So, I have only one rule).

(FF still has no problems, TVants is the only one now which is behaving problematic.)

Did you take multiple backups? This happened for FF too so I guess that there is some missing info to dig.
As I just realized you are affected by a relared issue I woul like to know what hapens if you add TVants manually to D+ with ask permissions and then you train D+.

BYW does D+ view active processes with full paths option list Tvants using 8.3 paths?

I first added manually TVants (which works great), so I don’t think the information Tvants is shown in long path name is useful. But added manually, TVants works great.

I did not make backups, as the FF problem is tracked down to Google Talk (see my link in previous post): The first time FF is started after a reboot started using GT, FF is in 8.3. If I start FF the first time after a reboot using quick bar icon, FF is in long filename.

Is it possible I have some traces left from an old installation? I really would like to clean all possible registry items, is that possible?