CFP & Avast Updates

Hi – need a bit of help with CFP re. Avast Updates

I’ve got the latest CFP version ( running on XP Pro (SP2) with Avast 4.7 Home (Free)
The problem I’m having is with the Update Notification on Avast in conjuntion with CFP.
I’ve got the exact same setup on another system and the only difference is the firewall.

I can run the update manually and it’s fine - but I like the auto notifications (and running update from system tray).

What Avast seems to do is create on the fly avast.setup and setup.ovr and I was wondering if that’s the problem.

So far CFP has come up with 2 responses:

  1. [First Avast update attempt] It noticed the connection attempt and asked for rules – I’ve allowed UDP 53 and TCP 80 Outbound to all. And the update has worked. Problem comes on the next update it’s blocked even though those rules are in place. Secondly the icon in the application rules section goes from the Avast Icon to a white (i.e. non existent application) - which makes sense as Avast only creates the avast.setup file on the fly.

  2. Having removed the rules completely to try again (including re-boot). CFP didn’t even notice the connection attempt. Yet alerts are enabled.

[This process has happened a number of times (i.e. ghosted back to totally clean system installed CFP onto clean system — same deal]

This is from the Avast Log:

08.02.2007 18:24:03.000 1170959043 file GetNewerStampedFile:GetFileWithRetry failed: C:\WINDOWS\\onefile, servers.def, error: 0x20000004
08.02.2007 18:24:03.000 1170959043 package Tried to download servers.def but failed with error 0x20000004.
08.02.2007 18:24:03.000 1170959043 general Err:Cannot connect to (unknown:80).
08.02.2007 18:24:03.000 1170959043 package Transferred files: 0
08.02.2007 18:24:03.000 1170959043 package Transferred bytes: 0
08.02.2007 18:24:03.000 1170959043 package Transfer time: 0 ms
08.02.2007 18:24:03.000 1170959043 file NeedReboot=false
08.02.2007 18:24:03.000 1170959043 general Return code: 0x20000004 [Cannot connect to (unknown:80).]

Avast runs through a whole list of server addresses (download?? each reports the same error (haven’t posted the whole log here for obvious reasons).

Finally my Network Rules are the default rules.

Would very much appreciate help on this. I really like Comodo - seems very stable and runs a treat - except for this.


ps. One other thing I’d like to add - with regard to improving CFP is the log - I find it very poor in relation to other Firewalls. That said thanks for providing this excellent package free!

I got same problem!!
If you know how to fix it, please let me know.

G’day Rachel and Alan,

This problem would seem to be caused by the dynamically generated exe that does the autoupdate. I would expect CFP to simply ask for permission for the newly named app to access the net, but would expect it to do this for each uniquely named instance of the autoupdater (that would be a pain in the bum - I’m struggling to understand why Avast needs to generate the autodater dynamically).

There are similar issues with some CD/DVD copy protection schemes that generate random executable names.

Don’t know why the app icon changes to white (non-existant), unless there is a timing dependancy.

I’ll think on this a bit more and will post back when/if the mental lightbulb illuminates.

Ewen :slight_smile: