CF blocking sites related to Citadels

Since a couple of months I have ¨¨ listed as a blocked host name in the firewall. This site was a part of the Citadel/Zeus network.
A couple of days ago I could no longer access sites I normally visit, like,, but I could visit and

After a lot of searching I found out that the blocked host name “” is the culprit: if I delete it from the list, all goes well again, if I add it again, I can no longer access those sites with browser (Opera, Chrome).

On another PC I tried to access same sites, no problem. I than added the forementioned host name to the blocked sites list and bingo, no more access.

Can anyone verify this behaviour and better yet, offer an explanation?

Windows 7, Opera 12.10, COmodo Firewall 5.12.256249.2599

There is a bug reported about this.

I tried the urls in v6.1 and they worked. Initially only would get blocked but flushing Windows DNS cache fixed it. It looks like it is fixed in v6.1.

Forget what I said in the above. It looks like the bug is still around. I still had the host name in the block list and it blocked a bunch of pages today. I did an image search with Google and 80% of the page would not show images. After removing the host name it loaded fine.

Thanks, I also found the article pointing out this bug. Hope you get this worked out eventually.

I also hope it gets fixed. Even though it is not suited for blocking big amounts of hostnames it should function.

On a side note. Us mods are not Comodo employees. We’re end users like yourself who like Comodo products and wear a badge. By the way: welkom op de Comodo forums Medelander…