CESM2 (40729.6) - Feedback


First of all congratulation on this amazing software.
You really did a great Job!! Like Melih said, its a really sexy software.

Here are my feedbacks so far, and I will keep posting more in this same thread as soon as I start working with it more often.

August 4th, 2011
. I donwloaded the installer. Icon details need attention (very poor and cut edges). Is what people see first, detailes need to be finished. :azn:

. On Console, Computers > Create Group > Deploy agent on computers… > IP Addresses.
Ok, I need to expand a little bit in here. First of all, TARGET TYPE: I notices that it says IP ADDRESSES, CHOOSE THIS OPTION TO SPECIFY IP ADDRESS MANUALLY. At first, I thought that only IP addresses would be allowed to enter and not FQDNs (domains). After selecting this, I go to the next step, IP ADDRESSES: input appears to add the IP address or the FQDN. I added my domain just to give it a try (note that by this time I thought only IP addresses could be added but just thought on trying out) and then click the arrow to go to the next step. The message in red appeard: YOU SHOULD SPECIFY AT LEAST ONE IP ADDRESS. This message gave me the impression that definitely a domain couldnt be added. Clicked it again and the same red message appeared.

After a few minutes, trying to figure it out… I found a PLUS (+) sign next to the input, on the left side. That actually gave me the impresion that I could add more inputs to add more IPs. After clicking it, I figured out that it was to actually add the IP address that I typed in the input, and then I should click the arrow to go to the next step. So as you can see, the ARROW TO GO TO THE NEXT STEP, the PLUS SIGN, and the instructions saying that only IP ADDRESSES CAN BE ADDED, the three elements confused me about adding an agent.

So in conclusion, with this I would give 3 suggestions: 1) The arrows to go to the next step should be bigger or be placed in other place where you can see them. Or perhaps a more lightful color, other than grey. Because to be honest, at the first step I was waiting for the application to move on (since the other options at the console, respond in that way). 2) I noticed that domains can also be added. So this should be added in the description along with the IP addresses. 3) The plus sign, should be changed to the string “ADD NOW” or something like that. And to be moved AFTER the input, not before. This way it will give the idea that people should type and press the button. Because the way it is right now, its not intuitive (because of the order or the elements). Once the IP ADDRESS/FQDN is added, it should be move to a list (not under the input).

. No Logout button?

So far this is what I could find out while adding agents.
If I find more stuffs, like I said, I would keep posting in this thread.

But in resume, you have bulit a very strong beta release. Congratulations! 8)

I used the manual for this step:
Adding Computers by Manual Installation of Agent and CIS

Just a couple of observations:
. Defense+ alerted me about AgentSetup.exe. I believe this is normal on beta right? Later it will be added to the white list?
. On CIS (at the endpoint), I went to MORE > MANAGE THIS ENDPOINT. Would like to let you know that deplyment run smoothly. However, after it finishes, I can see this error in the following message: “Agent was successfully delpoyed”. Should be dePLoyed, right? ;D

Most important thing. Dont know what happened to my server, but License Key is out.
How can I re-type it in, without reinstalling the whole application?

Ok, I found where can I put the license again but is not working.
So I uninstalled the software and re-installed it. And now its saying that the license has been used in other machine (Im actually using the same machine). Please help!

thank you for the feedback!

pls keep it coming… very useful.

Thanks Melih. I would like to keep contributing.
But as I mentioned in my last post, I need my lincese issue to be fixed.

I dont know what happened but all of a sudden, my license changed from 365 days left to 0 days left. I tried re-typing it and ESM wouldnt take it. So I decided to uninstall and reinsall it, but know during the reinstall process when I want to activate my license, it says that the license has been used on other machine.

So I am kind of stopped here. Because I dont even have the previous installation to keep trying out. Can someone help me with this license issue, please?

w-e-v, did you change anything on the server machine? This could happen when server hardware and/or OS changes. As this was not expected to occur frequently, the supposed remediation for the user is to contact ESM Support asking to re-enable the license for the new hardware. Maybe this is false-positive in your case, we are investigating this issue.

Nope. Didnt change anything at all on the server side. It just stopped working all of the sudden.
Sadly I cannot send any logs since I uninstalled the software and I dont find a way how to reinstall it.

Do I have to contact ESM Support for re-enabling the lincese (where and how-to)?
Or it will be automatically re-enabled so I can keep trying out?

Hi W-e-v,

We cleared the Machine Code from your beta license. You should be able to re-use the same license key now on your machine and continue your (excellent work at) beta testing.


Thank you glen, appreciate your assistance with the license key.
I will take note of it, if it changes again from 364 days to 0.
And possibly send some logs in any case.
Tomorrow I will try to re-enter it.

As additional feedback…

The first time I installed CESM 2.0, I was using the FULL PACKAGE.
However, after installing it, I went to the browser and had to install Silverlight.
Would be great if this could be added in to the FULL PACKAGE, dont you agree?
Specially if its for free.

just a quick question
i keep getting this pop up everytime i open the console. is it a problem on comodo’s end?

i am working on setting everything up and i will give some feedback once everything is complete

[attachment deleted by admin]

i want to use CESM to manage a couple different computers that already have CIS 5.8 installed. what ip do i use to manage them from the CESM?

Hi wasgij6,

We’ve prepared a help page for just this: Comodo Help


You can essentially ignore this error that occurs on browsers not running on the server console, it is because the server does not have a ssl certificate for the hostname you are using to access it. A future beta/rc will have the ability to import a cert in the Configuration Tool. Also, there is a way to export the server’s cert into your browser to eliminate this warning … Look for a help topic coming soon.


thanks for your help glenmm

after adding my endpoints i have noticed that only having the firewall installed causes improper errors in CESM
it says one of my endpoints is outdated well it cant be updated since its the firewall and defense + only. is there anyway that CESM can detect what is installed

[attachment deleted by admin]

first thing i would like to see fixed is part of the GUI. when i click on one of the grey tile to select something it doesnt work it only works if the descriptions are clicked within the tile. i would like to be able to click the grey tile anywhere

being a home user im not used to using ESM’s so maybe to make things easier can a few steps be added into the GUI when adding a computer that already has CIS installed. its a simple process but i had to look through the help guide. maybe just add a alert saying what port is currently configured in the configuration tool and maybe say what the local IP is of the computer running CESM.

i really like the animated grey tile buttons and like how they change color on the dashboard when action is needed or something is wrong

idk if its just me not being used to working with Endpoint security but i found it kind of difficult or confusing when creating a policy. i guess my first thought of an ESM was me being the admin and managing the endpoints, having the ability to configure CIS on the endpoints however i would like, being able to change all aspects of CIS like i would on my own machine. Maybe this is just a misconception i have about endpoint security idk. im sure someone can enlighten me

i have now been working with CESM for a couple hours and really like it so far. the interface is awesome a decently easy to use. Once i get more familiar with working with it im sure i will find it invaluable.

thanks for the great product comodo!
keep up the great work

You describe how typical enterprise-designed consoles work, and what that does is require you to re-learn a whole new way to change the settings you’ve been managing at the endpoints – in fact, you usually have to scrap all the settings you had at the endpoint and recreate them at the console, which is why deployment takes so long. With this business edition we’ve taken a “ghosting” strategy with ESM 2.0 which is more comfortable for smaller businesses, where the complexities of the settings of an endpoint are best managed at and imported from the endpoint that is tested and configured with those settings. Then those settings are distributed, in our case, as policy to other endpoints. It makes it much simpler to manage, much faster to deploy. When changes are needed, it’s usually because the endpoint has changed. Meaning you’re at the endpoint installing some new software, making some settings to CIS (in local mode), testing those changes at the endpoint, and reimporting the changed policy to update all other computers – rather than making a change at the console, waiting for it to get to the endpoint, testing back at the endpoint, going back to the console to make another change, etc.

–Glen Marianko
Product Line Manager

The bug ID: 5062 for this case was posted. Thank you for your feedback.

w-e-v, thank you for the feedback. We completely agree with your suggestion and we are working on it. Yes, Silverlight is free but standard EULA does not allow a redistribution (http://www.microsoft.com/getsilverlight/get-started/install/license.aspx?v=4.0.50401) . So you have to download and install it manually at the moment.

I installed it on my Home system.
Configuration: Win 7 x64, CIS 5.8 Beta

Installation went well. In the end it asked to start CESM configuration tool, I clicked OK and got this strange error message. (attached below)

To log in to CESM console it wants silverlight to be installed. I installed silverlight, but my firefox nightly x64 still asks me to install silverlight (may be x64 silverlight is not there…)

I tried to open the link in Comodo dragon and got the attached screen. (By the way, why is the https crossed in the url ?)

Someone please guide me… what should I do? (I am planning to uninstall it completely and install it again, can I enter the same license again?)

Note:I have read wev’s post just now, I too agree with him. If silverlight is compulsory to enter CESM console, it better be integrated in to the package…

[attachment deleted by admin]

Completely uninstalled, rebooted and reinstalled. Still the same error.