Certificate Error sites in IE not working

COMODO is installed on Windows Vista Business Edition, along with Spyware Terminator and Windows Defender. It’s working well, except for web sites that have digital certificate errors in IE7. Which is one of our work sites where an incorrect certificate is intended to dissuade the casual and curious.

But, with COMODO firewall enabled I cannot navigate past the IE7 certificate error page to the actual content. The symptons are:

  1. I enter the website URL into the browser, and it goes to the warning screen:

There is a problem with this website’s security certificate.

The security certificate presented by this website was issued for a different website’s address.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.
We recommend that you close this webpage and do not continue to this website.
Click here to close this webpage.
Continue to this website (not recommended).
More information

If you arrived at this page by clicking a link, check the website address in the address bar to be sure that it is the address you were expecting.
When going to a website with an address such as https://example.com, try adding the ‘www’ to the address, https://www.example.com.
If you choose to ignore this error and continue, do not enter private information into the website.

For more information, see “Certificate Errors” in Internet Explorer Help.

  1. I then click the ‘Continue to this website (not recommended)’ link and the browser tab changes text to “Certificate Error: Navigation Blocked”. The browser does nothing for a minute or so and then I get this error page:

Internet Explorer cannot display the webpage

Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address.

What you can try:
Diagnose Connection Problems

 More information
  1. If I disable COMODO firewall and try again there is no problem, it gets through the certificate error page and connects to the web server.

I have set IE7 as a trusted application, and looked at the help text around digital certificates (which pertains to .exe files, not web pages as far as I can tell) but since this our demo site I would like to access it with the firewall on, not not off.

Welcome RegusCity,

Do you see anything coming up in the Logs while trying to do this.Also do you IE7 set to “Web Browser” policy in your “Application Rules”
Something else you could try is go to Computer Security Policy and “Remove” the entry for IE7,apply to close all windows,make sure it`s gone then let Defence+ learn its actions again.