cDrive login problem

I created a free cCloud account a few days ago, and activated it. I can login to using a browser (Firefox) and look at the various pages (Comodo Online Storage, Comodo Membership, My Account, etc.). These are all ok and show that I have 10GB.

I can upload files to the cloud using the web browser, but I cannot get the cDrive program to run properly so that I can use the cloud like a local disk.

I downloaded cDrive, but when I start it I can’t login. It initially says “Connection with Comodo cloud server has been lost. Retrying in n seconds”. After the automatic retry (which also fails) it says “Wrong user name or password provided”. But I am providing exactly the same username (same as email address, and as listed on My Account page) and password as I use to login via a browser.

I have tried 2 versions of cDrive, initially and then but they both have this same problem. This perhaps suggests that the problem is to do with the cCloud user database, or that there is a general problem with cDrive using the internet connection.

I am running Windows 8. I have tried running cDrive in Win 7 compatability mode, but no difference.

When I double click the desktop icon to start cDrive, then its icon appears in the icon tray (but no login window is shown). If i right click the icon tray icon, the Open and Sign Out items are greyed out. If I double click the desktop cDrive icon again, then it displays the Login window (with problems as reported above). If I click Check for Updates, it displays “Could not connect to update server”. If I click anything else (e.g. Help) then it opens a web browser page.

This suggests that cDrive has a problem when it tries to access internet services directly, rather than just accessing a web page.

I am pretty unimpressed. 10GB is useless if you can’t actually access it!

I have the same problem and sent a ticket 2 day ago no response i guess they dont care abot free account client


I need to know if your passwords contain any special characters beside letters and numbers so we can check the issue.


No, nothing special in my password - but that’s irrelevant, anyway. I have now solved this problem myself.
After more experimenting, I realised that several other programs couldn’t access the internet either, including Windows Help & Support! I suspect that the problem affected 64-bit programs but not 32-bit programs, since the ones that worked (e.g. Firefox) were 32-bit versions (I think).
After hours of tearing my hair out and searching various web forums for ideas, including many that had no effect (e.g. resetting WinSock) I came across a pointer to the solution.
This said “Some programs communicate with the internet through Internet Explorer” and suggested checking that the “Use proxy” was not ticked. Well I never use IE (well hardly ever…) but I checked it anyway. The Proxy was already unchecked, but under File there was a tick against “Work Offline”. I unticked this, and voila! everything now works ok.
I discovered that IE had recently been automatically updated to version 10, and presumably the Work Offline somehow got ticked in this process. Since I never use IE, I hadn’t noticed.
But Hey… this is pretty obscure. Why on earth should the average guy (and before I retired I was a professional software engineer) expect that a setting in IE should affect how other unrelated programs behave? I think that COMODO should at least include some info about this in its Help pages. I have spent several days of fruitless effort over this.

It working now