CD will not run sandboxed limited virtualised [DIAGNOSED]

Problem description: Dragon will not run sandboxed limited with (file and registry) virtualisation. Whereas Chrome will if run with -no-sandbox and -single-process command line switches. The switches do not seem to help with Dragon. Dragon will run unsandboxed on my machine.

  • CIS version: 4.0.135239.779 x32, Dragon 4.0.1.6, Chrome 5.0.342.8 BEta
  • Your Operating System (32 or 64 bit, Service Pack revision, and account privs: XP SP3 32 Bit, admin account (on Pentium 4 CPU 3Ghz, 4GB RAM)
  • Other Security and Utility Software Installed: See appended config report for details. Usually: Comodo - CIS, CVE, CIV, CLP, CSE, CAS, IVault; Other- Filezilla, Wallwatcher, Sony Ericsson PC software, Actual Window Manager, Routerstats, Revo, Process Explorer, Google Desktop, Process Tamer, Process Explorer, Kiwi Syslog, Idrive, Clipmate, Hotspotshield, Stuffit
  • Step by step description to reproduce the issue: Start dragon from command line with or without switches indicated above. Or start using shortcut. Dragon starts to load then closes without showing UI
  • How you tried to resolve the problem: N/A
  • Upload Memory Dumps on crash if you encounter any: N/A
  • Attach screenshots to your posts to clarify the issue further: N/A
  • Virus database version: Please see appended config report
  • Any other information you think that might be useful. CIS settings: See appended config report for details.

[attachment deleted by admin]

What version of Dragon and Chrome is being used?

Also, you’re using 512 MB of RAM? (That’s what 4Gb is, case does matter.)

Sorry, must have overposted, as I had multiple versions in my browser open for editing, one of which had version info for CD.

Have re-added the version info.

Memory as stated is 4Gb (well that is to say 4Gb installed, 3.2 probably available after memory mapping, video card use etc)

Mouse

Mouse,

Please be aware that G = Giga, b=bit, B=byte. There are 8 bits in a byte, thus… 4Gb = 0.5GB; Case does matter in this case.

OK, sorry, misunderstood, 3.2GB

Best wishes

Mouse

Hm, I can run CD 4.0.1.6 beta sandboxed as Limited, with -no-sandbox command (or -no-sandbox -single-process). :-
Also XP SP3 32 bit.

Yes that is what I have done, too.

Are you running it with file and registry virtualised & latest CIS version?

Mouse

Yes, virtualization (file and registry) was enabled.
CFW 4.0.138377.779

Wierd.

Have also tried uninstalling my two extensions (no difference), running unrestricted (no difference), running limited non-virtualised (no difference). Only thing so far found that makes a difference is no manual sandboxing.

Best wishes

Mouse

Have now tried rebooting, removing all except OS from memory (using EnditAll, and manually closing security software, rechecking with process explorer), ensuring no rules for dragon in computer security policy.

4.0.1.6 still will not run if sandboxed. The level appears not to matter, virtualisation appears not to matter

Otherwise dragon runs normally.

Tried re-installing yesterday as well. Plenty of hard disk space, plenty of RAM.

Jowa - are you sure about the Dragon version you are running? I have previously thought I had updated Dragon, when it turns out I had not. Had to uninstall and re-install. But ‘About’ clearly says 4.0.1.6 (with NO Beta) now for me.

This important as just about to publish a Comodo FAQ on running browsers sandboxed!

Mouse

OK now have tried complete uninstall, including deletion of all settings using Revo advanced mode, and clean using CSC. Then reboot.

No go after this - still same problem.

Finally cracked it. Uninstalled again, cleaned using CSC, then deleted previous Dragon virtualisation entries in c:\sandbox AND c:\vritual root and the corresponding registry keys.

Seems to be working OK now.

Presumably re-installation may not be refreshing all virtual copies, and there was some buggy stuff in files or registry relating to Dragon Betas. Sandboxing the file made it access these (but why when it was not virtualised as well as when it was virtualised?)

Something needs to be looked at here. By who do you think? CIS or CD?

Best wishes

Mike