CD shows light blue screen, does not load pages

I have used CD for a half year on a Windows 7 (64) system. It worked flawless until last week suddenly it only showed a light blue screen and refused to load any sites/pages. I have uninstalled and reinstalled the program, but the problem persisted. It opens with a light blue screen and refuses to show anything else. Anyone with suggestions on this matter?

Hi helix,
Suggestions only.
Have you tried hitting reload when it starts to see if it will get past the blank blue screen?

Try clearing your browser data.

Have you changed anything else on the system recently?

Possibly corruption in the User profile.
To create a new user profile in Comodo Dragon

Hi Captainsticks,

I tried both your suggestions. Deleting history does not work (tried that myself though not with the key combo) as it does not load the page where I can set that.

also renewal of the user profile has no effect.

Thanks for your suggestions anyway.

I wonder if it is only the latest version of Dragon that this has happened to you?
Can’t promise anything, but I have asked the other Mods to take a look at this.
Hope a solution is found.

Try uninstalling CD by using Revo Uninstaller Free. When prompted choose the moderate uninstall option.

Then restart your computer, download the newest version of CD, and install it. Hopefully at that point it will work fine.

Thanks Chiron.

Just a thought if the above fails you could try running the portable version and if that runs it might help eliminate if it is caused by obsolete/corrupt registry entries for Dragon.

Indeed the portable version ran without a glitch… thanks for your suggestions.

Hi helix,
With no installed versions present has the C:\Program Files\COMODO\Dragon folder been removed or at least is it empty?
If this folder still contains files try removing them or renaming the folder to Dragonold before re-installing.

Seeing that the portable works correctly, it still sounds to me as if it is possible that the user profile for the installed version is not creating properly.
Sorry we haven’t yet found the cause of this issue.

Hi Captainsticks

As I used revo uninstaller It must have been empty… The only leftovers I had to remove manually were some register entrys