CD hangs on first run

Recently my Comodo Dragon (Windows 7 64 bit) hangs every time I run it for the first time after I boot my computer.

My homepage is (which is not the most complicated website).

When I close CD en restart it the homepage is displayed within just a second.

What can be wrong?

Hi and welcome Ietsje,
Some modern browsers to tend to hang a bit on first start up, but if it is excessive try clearing your browsing data. Ctrl+Shift+Del
Also try disabling any third party extensions to see if any are causing the issue.

Thanx for your quick answer. I already disabled all my extensions, but the problem persists.

I also have a laptop (Windows 7 64 bit) with exactly the same extensions. On the laptop-computer CD starts immediately, without hanging.

What’s causing the difference between those two pc’s?

Does it hang opening Dragon or does it open and then hang loading your homepage?
Are you running the same Firewall/Anti-malware on both systems?

Some things to try,
On the problem computer check here and take notice of the final step (Deselect Automatically detect settings if it is selected).
Also temporary disable (Untick) Enable malware domain filtering (Comodo Secure DNS) if you have it enabled. Menu, Settings, Show advanced settings, Under privacy.

A similar problem happens here, on Windows XP, SP3, wireless internet connection, Toshiba Satellite laptop about 9 years old. What I do to get through the unreached home page or other page (usually home page when first opening browser) is click the X at the left of address bar to stop page from trying to load, and enter home page address and click to reload. The page is reached in about 5 seconds. Successive sites also then load comfortably fast also.

Is “Predict network actions to improve page load performance” enabled? If so try disabling it and see if that helps or not.

I’m experiencing the same problem with every update since V21 was loaded.

CD will open OK if I set the ‘Open new Tab’ Page’, but will not open if I set it to open or any other link.

It opens a blank white page & just sits there, says it’s loading but doesn’t ??? If I click the ‘New Tab’ it opens immediately!!

I have uninstalled & re-Installed CD & the Default profile several times but it hasn’t solved this problem.

If I use a gmail desktop shortcut with the ‘Target’ = “C:\Program Files\Comodo\Dragon\dragon.exe” --app=

and ‘Start In’ = “C:\Program Files\Comodo\Dragon”

CD hangs in the exact same way!!


Also found a solution…

Settings–>Privacy–> uncheck the Enable phishing and malware protection option.

That’s a worry since CD is supposed to offer more security!!! and the solution defeats it. sigh