CD "Enable malware domain filtering" (Comodo Secure DNS) option not working

I do not know if that is just me (As I can see by the first post in this category I was not the only one) but, after a couple of days of using the newest CD my browser had stopped working, and leaving me unable to even connect. That was until I had unchecked the option to CD “Enable malware domain filtering” (Comodo Secure DNS)
This is

Try clearing your DNS cache by running ipconfig /flushdns from a command prompt. I have no issues connecting to sites when enable malware domain filtering is turned on.