CD DEP Violation Version All V21's including V21.2.1.0 (154005)

CD crashes with a DEP violation, randomly !! The crash report tells me it is Dragon.exe & Dragon.dll. Since I cannot set CD as an exception in DEP exclude box, I have been unable to resolve the issue.

I have un-installed CD & the user profile several times & re-installed CD but it hasn’t resolved this issue. I have tried to isolate the issue by disabling the Extensions, but haven’t been able to find a solution.

Plugins/Themes/Extensions: Ad-blocker for Gmail™ 2.7, Adblock Plus (Beta) 1.2, Autocomplete = on 1.0, Do Not Track Plus, URL Shortener extension 1.32.4, Google Dictionary (by Google) 3.0.15, Speed Dial 2,

Plugins: Google Talk (2 files) - Version:
Foxit Reader Plugin for Mozilla - Version: 2, 2, 1, 0530
Google Earth Plugin - Version:
Google Update - Version:
Java (2 files) - Version:
NVIDIA 3D (2 files) - Version:
NVIDIA 3D Vision plugin for Mozilla browsers
Shockwave - Version: 11.6.6r636
Adobe Shockwave for Director Netscape plug-in, version
Flash - Version: 11,4,402,265
Shockwave Flash 11.4 r402
Silverlight - Version: 5.1.10411.0
Windows Presentation Foundation - Version: 3.5.30729.1 built by: SP
Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Default Theme

Windows VISTA Home Premium SP2

UAC Disabled

System Drive C:\

CD is installed at the default program location.

Run as Administrator.

Chrome IS NOT installed.

I use the ‘Crash Recovery’ option which usually works OK for a while, but will crash again during the same session, sometimes almost immediately.

The Application Even log:

Log Name: Application
Source: Application Error
Date: 10/09/2012 8:22:46 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: Home-PC
Faulting application dragon.exe, version, time stamp 0x5049ceea, faulting module unknown, version, time stamp 0x00000000, exception code 0xc0000005, fault offset 0x00000000, process id 0xa60, application start time 0x01cd8ecd5687019f.
Event Xml:




Hope all this is enough to help me resolve this ongoing & annoying problem…

How do you uninstall?

The problem could be in the Registry.
Re-install the program and then uninstall with RevoUninstaller(Try to get the free on the Downloads page) under the “Advanced Mode.”

If that does not work, try the uninstall thing again but this time get Eusing Free Registry Cleaner and do a scan(after uninstalling), then attempt a Repair. Restart and install again.
Other reasons is that your RAM is faulty, added new RAM lately or tampered(loosened) with the one installed?

Revo free only works with x32 applications. X64 applications requires the registered version.

@ John Buchanan
Thanks John, I use the 32bit version of VISTA.

@ megamax…

I have twice, already, used ‘Remove CD’ un-install, including the ‘Remove user profile’ option & re-installed CD with a fresh download.

Before re-installing CD, I ‘Explored’ the program listing for any remnants of CD, used ccleaner to check the Registry & as usual (lazy programming) removed anything ccleaner found before rebooting & re-installing.

I’ll run the Mem test to check it. … I use 2x2gig of RAM with an AMD Athlon 64 duo CPU which has hardware DEP. I also tried the ‘Windows only’ DEP software option, but that didn’t fix it!

I’ll give Revo a go!!

This problem has been plaguing me for weeks, I’m almost ready to dump CD & return to Firefox.

Does the endless updating ever end!! sigh

Let’s not forget that Comodo has an uninstaller, forgot if it checks X64 applications as well, though.

[at] megamanx (oops…sorry)

I use the CD uninstaller.
Have to wonder what it leaves behind, if I need to use REVO & other uninstaller’s ??

Under normal circumstances using third party uninstallers should not be required, I am more inclined to think it is an extension/plug-in compatibility issue.
Try running with all extensions/plug-ins disabled check here for required steps to disable all.
If this solves the issue remove the switches and manually disable the suspect extensions/plug-ins.

@ captainsticks

Thanks for the tip.
I’m running with it now.
Due to the random nature of the problem, it’s going to take days to try & resolve this issue. I’ll try a binary half at a time enable\disable approach to speed it up a bit.

Does the Windows Event Viewer provide more info that might be useful??
I supplied all I thought might be useful in an earlier post.

Event Viewer told me that something is up with the Ram or Registry.

[at] megamanx…

Thanks for the RAM & Registry comments.

RAM checked OK.
Ran RegSeeker V1.55 & it found ~1900 errors which it cleaned up. (Doesn’t say much for Microsoft’s claim that Windows looks after the Registry without using a cleaner!!)

I then disabled all Plugins & Extensions…

CD ran ok for about 10 hrs.

Re-enabled all plugins…still OK…

Enabled Extensions one at a time & found what seems to be the problem… an AdBlocker.

My solution which is working OK so far is:

Open CD & disable AdBlocker.
Close CD.
Reopen CD and enable AdBlocker (not Adblocker+)

When finished with the browser & before closing it, disable AdBlocker.

When you want to use CD again, run CD & then enable the AdBlocker. (The AdBlocker should not be enabled when CD is loaded, only after it is started…)

If AdBlocker+ is enabled (using the procedure outlined) CD will eventually crash!

AdBlocker has been OK, so far!

I’m guessing, but is there a memory allocation problem, either in CD or the AdBlockers.

Since AdBlocker seems to be OK but AdBlocker+ will crash, eventually, it suggests maybe a memory allocation or buffer overflow problem in CD if an Adblocker is enabled & allowed to load with CD but is OK if enabled after CD is loaded??..

Any thoughts??