CBU v3 (pub release) - Error Code 33 for Differential BU

I’m getting error code 33 when attempting a Diff BU of Disk 0 MBR and C: partition - error msg says “One or more partitions do not have a correspondent”.

I’ve re-tried a number of times using both “Make new BU” and “Choose existing backup” options and also trying the Incremental option. I’ve also tried creating a new Full BU as the base (in case I did not specify the disk parameters correctly). Still no luck.

Subsidiary point: I don’t understand the “Make new BU” (MnBU) option for a differential or incremental BU. I’ve re-read the manual countless times and I am coming to the conclusion that something is mixed up in CBU processes. I would have expected MnBU to allow me to select a previous BU (full, diff or inc) as my new base. However, it doesn’t (or at least it doesn’t seem to). However, when I opt for “Choose an existing BU” (CeBU), it does allow me the to choose an existing BU as my base. Surely that is the wrong way round!? I would have expected MnBU to allow me to select an existing BU and that CeBU would simply backup on the most recent BU (full, diff or inc). I’m not a programmer (so don’t know the right words), but my guess would be that the GUI options are pointing to the wrong sets of code !? (The only alternative explanation is that I’m a complete dunce)

I’m confused - or should that be - CBU v3 is confused!?

Should have done a more thorough search before posting the last - I had completely forgotten I had this problem with the v3 beta and posted then. It appears I have two problems - something about my system that CBU doesn’t like and I’m going senile. I’ll go play with my setup and post back idc.


I want to clarify a few aspects.
“Make new backup” - creates a new base for incremental/differential if one doesn’t exist already.
“Choose existing backup” - allows you to choose a specific base for incrementals/differentials

Whenever base doesn’t anymore, a full backup will be created.
Please post back if you encounter any other problems.


Thanks Emanuel for posting. A rather long response from me I’m afraid as I’m far from sorted. I have however, now seen a new full BU created as the result of a failed differential BU (as you described). Also I have found a scenario where CBU seems to get confused. So I thought I’d post the results of some tests.

Before testing, I ejected my ready-boost flash card and un-installed the app’ VirtualDriveClone and rebuilt the MBR. I completely un-installed CBU, cleaned the registry and reinstalled CBU and rebooted. I used my Q partition (which is a primary partition) for the test to avoid any possible issues from backing up an active system partition. All tests were run in immediate succession.

Test 1: Full BU of Track 0 & MBR plus Q part’ to external USB drive - successful.
Test 2: Diff of 0/MBR + Q with Create New BU option - failed with code 1 (Could not retrieve disk information). Hitting Cancel and then New BU takes me back to Step 1.
Test 3: Diff of 0/MBR + Q with Choose Existing BU option - failed with code 33. Hitting Cancel and New BU takes me to a new step which says Differential BU Selected and allows me to re-select the source. I’ve never gone beyond this point before as I assumed it would attempt another Diff. However, I chose 0/MBR + Q again and followed through where-upon it indeed created a new Full BU as you described. However, on hitting Finish and New BU again, it took me back to that step once more rather than the usual step 1 page. This time I hit the Back button and got the usual step 1 page except it was now showing all three drop-down menus simultaneously (BU type / Create new or Choose Existing / BU Source)! Odd I thought, but hit the BU source menu (just to see), chose My Computer and selected Q partition - I got the message Wait … I did and nothing happened. CBU seems to get a bit “confused” here - I certainly am.
Test 4: Full BU of Q part’ only - successful.
Test 5: Diff of Q with Create New option - failed with code 1 - Cancel and New BU takes me back to the usual Step 1 page.
Test 6: Diff of Q with Choose Existing BU option - successful.

Incremental tests went the same way as their Diff counterparts.

So conclusions and questions:

a) On my system (laptop) at least, CBU does not like differential or incremental BUs which include Track0 & MBR. While writing this, I’ve also tried with CIS Antivirus and Defence+ disabled to no effect. I suppose I could try a complete reformat of the hard drive and Windows re-install, but I’d rather not have to. Can you or other members offer any further thoughts please on where the problem might lie? (Circumstances prevent me from testing it on my Desktop PC presently.)

b) Interesting that I get code 1 on test 5 but Test 6 completes! Edit: actually it’s not interesting, but it does reinforce point c)

c) Selecting Differential or Incremental BU type along with Create New BU option does nothing at all on my system and I’m still wondering why CBU allows those selections in combination.

Emanuel, I just found your post How To Collect Debug Information. Question: does debug have to be re-enabled before every debug run or is it enabled permanently? (I’m guessing the former.) Also, if run multiple times, is debug information appended to the dump file or is the file overwritten? Lastly, how can I read the dump file myself?



Debug information is not needed because our QA department reproduced these issues.
They will be fixed in an update.
Thank you for reporting them.

PS: Debugging remains enabled only until first restart.