CBOclean 4.26 multiple instances


I need help - when one of my limited users log into their accounts 2 instances of CBOclean load. To try and fix this problem I have already tried:

  • Completely reinstalling (restarting after uninstall and then again after install)
  • Cleaning the registry between steps
  • Deleting the user profile and creating again

This does not seem to happen on my administrator account.

Any ideas would be welcome.



I have temporarily fixed this error by removing the check in ‘automatically start BOclean at bootup’ in ‘Configure BOclean’ and starting the program manually in the startup folder.

However, I would still like to get to the bottom of this problem.



my guess is that BOC was not properly uninstalled before installing the new version and so now two instances of BOC are running…

to try to fix the problem, i would uninistall BOC, reboot, and then make sure that there are no BOC-files leftover in “c/program files” or in “c/documents and settings/all users/application data”, and then remove any BOC-regkeys that might be leftover in the registry, and then reinstall BOC…

the problem could have been from running the uninstall while BOC was still running in realtime and so it didn’t properly uninstall…

maybe there are some instructions, somewhere, for “manually uninstalling BOC”, when necessary…

HOWDY, stranger! Definitely shouldn’t be happening as BOClean will actually check for the presence of another copy of itself running and any additional instances will just exist upon startup. Somehow, one copy is not seeing the other copy even though the startup is in HKLM and there shouldn’t be any other startups at all other than the original. Somehow the HKLM startup is being mirrored to that user account though I haven’t the foggiest as to how or why … only thing I can suggest is a removal/reinstall and see if that does anything …

I have tried reinstall before - however I will give it another try. I have checked the HKLM of the admin user and there is only one instance. The wierd thing is to try and fix the problem, I did this:

  • Delete user accounts effected (presumably deleting their registry)
  • Install CBOclean
  • Recreate user accounts (Should copy the one run instance from admin registry)

Problem returns. Could this be a problem with RejZoR’s 4.26 new tray icons? - as I also use these.


Heh! Glad to see I’m not the only one on “Asian time” … heh. Can’t see how it would be since that’s a “resource section patch” only … no, I’ve heard of this happening before, but it’s not BOClean. Bad news is that I have no idea as to why. :frowning:

So … I’ll describe what BOClean does, and hopefully some other “lookenspeeper” might have seen something like this before elsewhere and might have a clue …

On Win2K, XPee and Vista, the HKLM Startup will kick up BOClean as soon as ANYONE logs in (BOCORE is a system service) and the “local machine” will start it under “quasi-admin” … when a limited or other user logs in, BOClean is already started and is doing so under the local machine. Traybar comes up and if it’s not admin, traybar notifies BOClean that a new traybar has appeared (this is also why BOClean will reappear automagically when explorer itself crashes and the traybar goes away and then comes back, unlike some other proggies that vanish for good). At no time, is there another startup call.

So somehow, that limited account is getting a kick start from something else which is reading that HKLM key and calling BOClean as though the system has just started. And even worse, the newly started copy is unable to see the other copy. This can happen when you have two different versions of BOClean on the system, but would occur at the very first login and also be consistent since BOClean will spot an already running copy of itself and any other than the first one will exit upon finding a copy of itself.

Something else is involved, but I cannot even fathom what or why … otherwise we’d see this more often. :frowning:

I tried a restart but had no joy. Attached are 3 screenshots FYI.


[attachment deleted by admin]

I see it, don’t get it, but the only way a second copy could come up is if BOClean can’t see its “other” window or its mutex. And the HKLM start should only create one instance … have been going over and over on the code and can’t find any problems with how it’s written or we’d see this happening more. About the only idea I have has to do with an obscure bug in XP, dunno if it’ll help but it’s all I’ve got …

Try this …

Open “My computer”

Go to Tools>>Folder options>>View

Under “Hidden files and folders”, uncheck “Launch folder windows in a separate process”

Then reboot and see if that makes any difference. If it happens to be ALREADY unchecked, then check it, reboot, then uncheck it and reboot … Explorer’s been known to write “qwap” to the associated registry entry which can cause “ghosts” … far-fetched, but that’s a “known issue” … about the only one I have other than squirrelly permissions settings …


I tried your steps but still no joy (:AGY).

I had a little experiment and my copy of CBOclean does not detect itself as open. I managed to manually launch 4 instances of CBOclean before it wouldn’t launch another.

I have trawled through the registry and haven’t found anything so far.


try dumping the “rejzor 4.26 icons” and see if that resolves the problem…

i tried launching a second instance of BOC, but i still only saw one BOC icon in the systray, and one instance of BOC running, in “task manager”…

when you uninstalled BOC 4.25, before installing BOC 4.26, did you check to make sure that there were no BOC files and/or folders leftover in c/program files/comodo/cboclean", after having uninstalled BOC?

you could try uninstalling and then reinstalling BOC… before running the uninstall, make sure that all BOC processes are CLOSED… use “task manager” to close all BOC processes before running the uninstall… then run the uninstall… then, reboot… then, after having uninstalled BOC and rebooting, make sure that no BOC files are leftover in “c/program files/comodo/cboclean”…

you could also check to see if there is a “BOC.426.ini” file “leftover” in the “c/windows” folder, or an “unboc.exe” file, also in the c/windows folder, and delete them, if they are… there is also a “BOC” folder in “c/documents and settings/all users/application data/”… if there are BOC folders there (after having uninstalled BOC and, then, rebooting), delete them…

you could also try to remove any BOC regkeys that might be leftover, after having uninstalled BOC and rebooting…

after having uninstalled BOC and rebooting, look in “task manager” and see if there are any BOC processes running… there shouldn’t be any BOC processes running after you have uninstalled BOC and rebooted… if there are, then there is a problem, somewhere…

after uninstalling BOC and cleaning up any leftover BOC files-n-folders and any leftover BOC regkeys, and, looking in “task manager” to make sure that no BOC processes are still running-even though BOC has been uninstalled, i would reboot, again, and then reinstall BOC 4.26… it wouldn’t hurt to check, again, to see if any BOC processes are still running even though BOC supposedly has been uninstalled…then reinstall BOC…

Weirdest thing I’ve ever seen … a little programming info for you related to this - BOClean detects another instance of itself by two means, first a mutex (these can be unreliable but “proper technique” requires that you try it anyway) and then try to open it again and if you get an error, then a previous instance is running. However under XP (when properly “tightened up”) as well as Vista, you can’t open the thing from “user level” and therefore using a mutex doesn’t work because it can’t be written to and therefore “isn’t there” … result, you can open instances until the cows come home because no error is reported.

So what WE do is we do a “FindWindow” on BOClean and pop it into a particular internal state to await that “probe.” THIS works on any version of Windows and is extremely reliable for detecting another instance. If its window is there and is found, BOClean bails as it’s already running.

So what’s going on here is the mutex is blocked, and apparently the FindWindow as well as PostMessage to itself and since there’s “no window” there according to your system’s arrangement, then we create one since “all’s clear.” I have NO idea of why that’s happening, but it apparently is … only question is why? :frowning:

Microsoft had a wonderfully reliable way of detecting and reporting a “previous instance” in Win16 (Win 3.xx) and BOClean still handles that as well though I doubt anyone is still running WFW 3.11 any longer. When Win32 came along, it no longer worked. So they recommended mutexes. Killed that in XP as being terribly useful owing to the “different consoles” design.

But if the traybar icon is there, then FindWindow should be spotting it. And for everyone else so far (including me, been trying desperately to set things so as to trigger the old “aha!” moment) it’s working. Definite mystery there, brah! :slight_smile: