cavwp.exe is always running and abusing the hard drive

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes. Every single time.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Reboot computer
2: Login to windows and listen to your hard drive being ■■■■■ overloaded without my permission and no way of stopping it in the settings.
3: Start process explorer to find the offending process
One or two sentences explaining what actually happened:
cavwp.exe is overloading the hard drive each time on windows login
One or two sentences explaining what you expected to happen:
When disabling AV, scheduled AV tasks and HIPS I expected it to stop.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Not applicable.
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
My current solution is to rename the offending process "cavwp.exe " to something else.

Exact CIS version & configuration:
COMODO - Internet Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Antivirus: Disabled
Auto-Sandbox: Disabled
HIPS : Disabled
Firewall: Safe Mode
Have you made any other changes to the default config? (egs here.):
Cloud disabled
Run cache builder when computer idle: disabled
Scan computer memory after the computer starts: disabled

Anything that sends file to comodo disabled.
Anything that mess with my files without out my permission disabled
I’ve had very bad experience with comodo deleting files for me without my permission when when told to. It still have the same problems. Reported but ignored.

I’m only using CIS as a firewall with an optional anti-virus scan when needed.

I can’t even remember what I turned off. The settings dialog is a mess and do not visually show which settings that have been changed from the standard configuration.

Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
NO! I have no guarantee that the backup-ed configuration will work when importing. It is a pain in the ■■■ to add back the settings manually for all programs. Too clicky.
I have installed this on a clean machine and it have the same problem.
Have you imported a config from a previous version of CIS:
I updated from a previous version so yes?
if so, have you tried a standard config - if not please do:
NO! See above.
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 Ultimate 64 bit
UAC setting: Default
account type: Admin
VM used: No.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=No b=No

[attachment deleted by admin]

Please attach a full dump of ‘cavwp.exe’ when you’re experiencing mentioned issue.


As there has been no response, I will move this one to “Resolved” section.

Thank you.