cavwp.exe crashes and Win10 hangs while opening with Firefox


I’m using CIS on Windows 10 x64 17763.557. Several times a day my system hangs (all apps besides windows explorer) for 30-60s, I’m not able to do anything during this time. After ~1 minute everything goes back to normal. Each system hang generates this Application Error event log saying that cavwp.exe crashed with exception code 0xc0000409.

While I cannot say with 100% certainty that CIS is the source of the problem, it is the only app that appears in the event log after system hang.

I didn’t provide any logs because I’m not sure which will be most helpful.

Can you guys suggest me anything?

Share memory dumps found in ProgramData\Comodo\CisDumps folder.

Folder is empty for some reason.

Hi nastiv,

Thanks for reporting,could for please check your personal message and provide the requested logs.

Can you also look in appdata\local\crashdumps for any memory dumps for cavwp.exe? Also can you try Comodo Internet Security v12.0.0.6870 to see if you still get crashing? And also look here for cavwp crash related events

System hangs and cavwp.exe crashes when I try to open with Firefox browser.

Important note: I’ve already described my issues in Bug Reports section on the forum -
At that time i didn’t know what was the reason. I was able to pin it to Firefox and and Mathi R suggested me to create new topic using required format. If needed I can edit old thread.

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
It happens ALWAYS after restarting/starting the PC and every few hours while PC is running. Right after first hang/crash I can visit without any problems. After not using the PC for a few hours it will crash again (not using sleep or hibernate, just turning the monitor off).
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Start PC
2:Open Firefox
4.System hangs, cavwp.exe crashes (exception code 0xc0000409)
One or two sentences explaining what actually happened:
System hangs for a few minutes and cavwp.exe crashes while Firefox is trying to load Most of the page is loaded, but not 100%.
One or two sentences explaining what you expected to happen:
I expect to load without my AV crashing and system not responding for a few minutes.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Didn’t find any possible help regarding the issue.
Any software except CIS/OS involved? If so - name, & exact version:
Firefox beta 69.0b7, also occurs on latest stable Firefox.
Any other information, eg your guess at the cause, how you tried to fix it etc:

  • it happens only on Firefox (though I’ve also tried Chrome Beta only - no problems at all)
  • turning on or off AdGuard doesn’t make any difference, cavwp.exe is still crashing
  • if i disable CIS completly, pclab will load without any problems. As soon as I enable antivirus module, cavwp.exe crashes when loading
  • windows explorer isn’t hanging. I’m able to open start menu and click on some apps, but all of them open at once after few minutes.
  • after few minutes everything goes back to normal

Also I didn’t find any files in:

but there are some folders regarding cavwp.exe in:

Exact CIS version & configuration:
CIS (same behaviour on, database 31229. Standard configuration after clean install.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
All modules enabled (standard config atm) except HIPS.
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a clean reinstall - if not please do?:
I’m using standard config after clean reinstall.
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
I’m using standard config after clean reinstall.
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Pro x64 17763.615, default UAC settings, local admin, no virtual machines.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=AdGaurd b=no

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
I will sent log files to Staff member/Moderator via personal message. I won’t post links here due to privacy concerns.

Hi nastiv,

Thanks for providing the detailed explanation about the issue, it will help our developers to address the issue efficiently :-TU.

Mathi R

I’ve sent the log files via PM.

Hi nastiv,

Thanks for sending the logs :-TU, I have forwarded it to our developer team they are checking it.

I’ve updated Windows 10 to 1903 18362.267. It’s better, but not perfect - cavwp.exe crashes half the time.

Please update to Comodo Internet Security 2019 v12.0.0.6882 and check again.

No crashes since I’ve updated CIS to Looks like it’s fixed, thanks for helping me out! :slight_smile: