Cavscan.exe does not scan files via command prompt[V6][M637]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:Yes, every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:

a:Open command prompt and type: Path to CIS\cavscan.exe Path to file to scan.

b:Observe that no scan dialog opens and no scan takes place.
c:This used to work, I would be glad to accept an alternative scanner. This is used by many in such applications as download managers to scan for viruses after DLing a file. Other security products offer this function.

  • If not obvious, what U expected to happen: Obvious.
  • If a software compatibility problem have U tried the conflict FAQ?: N/A
  • Any software except CIS/OS involved? If so - name, & exact version: No.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: Function for scanning files has changed in CIS and my request for help went unanswered.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:6.2.285401.2860

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: D+/HIPS, FW & AV
  • Have U made any other changes to the default config? (egs here.): Proactive.
  • Have U updated (without uninstall) from a CIS 5?:No.
    [li]if so, have U tried a a clean reinstall - if not please do?:N/A.
    [/li]- Have U imported a config from a previous version of CIS:No.
    [li]if so, have U tried a standard config - if not please do:N/A.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:W7 x64 SP1+all updates, UAC off, Administrator.
  • Other security/s’box software a) currently installed b) installed since OS: None.

[attachment deleted by admin]

Thank you for pointing this out. Please attach your diagnostics report and KillSwitch Process List so I can forward this to the devs.


Thanks Chiron, I have attached the diagnostic report .zip file. I do not use CCE and therefore not KillSwitch either, as far as I know. Thanks and enjoy, John.

[attachment deleted by admin]

Thank you. This has been confirmed by panic as well, thus I’ll waive the requirement of the process list for this report as it does not appear to be linked to an issue with any running processes.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Thank you, Chiron and you are very welcome. Enjoy, John.

Chiron, this problem is corrected in 6.3.294583.2937. Thanks much and enjoy, John.

Thank you for checking this. I will move this to Resolved.

Please let me know if the issue returns.