CAVS Email Scanning

I have email scanning selected for inbound and outbound and also mass-mailing. I have both “Display Animated Icon” and “Display Progress Indicator” checked. However, when sending or receiving, I do not see any displays. I have also selected to certify incoming and outgoing emails with no luck there either.

I’m using Outlook 2002. There is no indication that CAVS is scanning my emails and no certification notice on sent or received mail. I have searched the forum and seen this issue mentioned before but there seems to be no conclusive response from Comodo.

Is this something to do with my using Exchange server? I have had this problem with every Beta so far on my work PC and on the first two versions at home. (No longer using CAVS on the home PC as the first beta 2 caused too many problems and seemed to have major issues with my HP printer software). So far the only issue I have with the latest beta is the email scanning problem and some minor lags (hangs).

So far I am very impressed with Cavs (It is pretty awesome actually!) but I would love to sort out the email scanning problem. :SMLR

Same problem here, anderow; has been with each version… Some have had success by unchecking the boxes, clicking ok, and then rechecking the boxes for the email scans and certifications. That did not work for me.

I am using Outlook 2003, and also an Exchange server. Which could be part of the problem.

However, I notice by using Process Explorer, that no new process opens for email scanning, when sending/receiving email.


Thanks Little Mac.
I have noticed the same thing: no email scanner starting in process explorer - I have even tried starting the email scanner manually. The relevent process showed as running in process explorer but still no email scanning. Next time I rebooted after unchecking and checking the various boxes, no email scanning and no process showing.
A Puzzle! Hopefully someone may come up with the solution. I am sure it has something to do with Exchange server and that someone from Comodo or the forums will deliver an answer.

Meanwhile I still feel quite secure with Comodo firewall and the latest CAVS beta and look forward to even better security with upcoming releases.

we will fix this bug guys…

we are on it…


Great! If there are any specific logs, tests, etc that I can provide, pls let me know.


Thanks Melih,

and thanks to everyone at Comodo for the great Firewall and Antivirus. The antivirus has come a long way since the first beta and is on it’s way to becoming the best there is!


Hi Little Mac,
Did you get any error during installtion?
Can you pl export and send this registry kay “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2”
Step: Open regedit.exe and click on Registry Menu->Export Registry File"

Also pl let me know if cavEmLSP.dll exists in %System32% directory.

I have no cavEmLSP.dll in my system 32 directory. There is a copy in C:\Program Files\Comodo\Comodo AntiVirus.
I have attached the Winsock2 registration entry (I think).

[attachment deleted by admin]

Hi Anderow,
That is the main reason for failure. Please copy cavEmLSP.dll in system32 directory and reboot.
does it fix the problem?



No, no installation errors.

Yes, cavEmLSP.dll exists in System32.

I have attached the Reg key, and the LSP as well (in case something there will help)…


[attachment deleted by admin]

Tried this and I am afraid still no scanning or certification.

I am using Microsoft Exchange server to access my email using Outlook 2002.
It seems my emails are saved on a Domain ? - is this why CAVS is not scanning them because they are not actually on my pc?
If I open an attachment on an email it does not show in my recently opened files - the attachment shows as a temporary internet file when I view it’s properties. I hope this makes sense as I am not that savvy with servers etc?


Did you receive the email I sent, for the test files?


I still have the same problem with beta.
Has anyone managed to shed some light on why this problem occurs?
Will CAVS ever be able to scan emails when exchange server is being used?
Why are chocolate bars so much smaller than they used to be?


Chocolate bars are smaller now because of two things:

People are concerned about weight gain (if the candy is smaller, you can eat more without feeling guilty…).

The manufacturers have found they can sell the smaller bars for the price they used to sell the larger ones for, hence more profit (which they can do because of the first reason…).

There. All your questions are answered… ;D

Oh, yeah, the email scanning thingy ---- :THNK

I just submitted some troubleshooting files directly to the development team at their request. They’ve enabled some specific logging to help track it down, so we’ll see what that gives.


Thanks LM,

Hopefully the team at Comodo will sort out the email thingy soon and perhaps I can stop eating so much chocolate to calm my shredded nerves.

Incidently, the latest beta is giving me no other problems worth worrying about - just the annoying double pop-ups for each application allowed by HIPS.


I use windows xp. In my task manager I have the following files: cavasm.exe, CavAUD.exe, CavEmSrv.exe, CLPTray.exe, Cmain.exe, cpf.exe, and cmdagent.exe. If my nowledge is correct, please check your task manager for these files (processes). I hope that this will help chase any bug down that are in Comodo’s antivirus programs.