CAVS 2.0.17.58 Hangs Computer on Install

It’s a new machine, I tried NOD32, uninstalled it, tried to install CAV & the computer hung on reboot. Booted to safe mode, uninstalled CAV, rebooted, everything runs fine. Try to install CAV again, same thing. Ran Easycleaner over the registry, deleted a bunch of errors, tried again, same thing.
Machine is an AMD 64 X2 6000+, Win XPSP2, 2GB Ram, using Comodo Firewall, not much loading on start up, mainly system drivers, SB drivers, printer controls, etc.
Any ideas ?

Have you tried installing CAVS in safe mode?

:SMLR

I installed the same version on my Win XP SP3 Athlon 3200+ and while the computer doesn’t hang, I can’t get the CAVS main screen to open…just the systray icon.

I am running WinXP Pro SP2 with all updates to date, I have installed CAVS 2.0.17.58 5 times now, and each time with the same results you are getting. My other home system is Identical in OS, slightly less in Hardware, and NO issues to date after a week. This comp though has not been able to run CAVS properly. Start-up the last 2 install’s haven’t even run the Analyzer to determine safe programs so it has gotten worse. I have cleaned the registry each time and there has been no CAVS keys orphaned so the Uninstaller works fine it would appear, but yet I am at a loss to how to get it installed properly without causeing problems or lock-ups. Now I cant start ANY progy after install without it Freezing all but the task manager.I have installed in clean boot, safe mode, administrator in normal boot…No differences, always the same issue…Anyway, I really hope they get it right soon. I cant go unprotected…Who CAN?

Well UPDATE time. I have since then installed one more time and had to disable HIPS in order to get things running, as when the computer booted it stopped the CFP from starting and refused to run User Profiling. Once I did that, I was able to manually start the Profiling and am in the process of getting a profile complete so as to hopefully allow the correct programs myself. Which kind of defeats the purpose of hips…I must say though that if it is that effective against normal operations it could mean it will do a fine job at prevention of infection. The thing is this could also mean some type of malware that has infested this system although unlikely as ZASS was working great on it prior to the install of CAV, and had maintained a proper security stance, and kept me malware free for a long time running now. Online scans revealed nothing either so I am thinking possible issue’s or conflicts with certain software on this system although I am really hoping it isn’t something to do with Directory Opus, as it is hooked into the system quite strongly.Time will tell, I’ll keep you all updated…Cheers! (:KWL)

UPDATE!!!
Installed and working once I disabled HIPS, which I must add has had to be disabled to even start the firewall (CFP)despite the previous profiling being erased as of uninstal 1,2,3,4 And 5. I am running a profile right now, and will add manually those progies I know to be safe. Then I will reactivate Hips and see if that works. Will keep you updated…

CS5,

The fact that the system was locking and yet wouldn’t run the profiler is of concern. Not necessarily meaning malware is present, but just that there’s been a rather serious conflict. As applications hook more and more into the core, this will unfortunately probably become more prevalent. For the most part, kernel mode hooks are only necessary (afaik) for security applications, and are considered a necessary evil even there. It is crucial that they are done properly. This is a part of the reason for using SafeMode to install/uninstall any such applications.

The profiler is there, btw, to help reduce popups that are the bane of any HIPS (from user standpoint); ie, to make it more “quiet.” There are tons of applications and processes that can be certified as “safe”, so the user won’t be quite as deluged by HIPS alerts. Most HIPS do this in some way or other - either a “hidden” safelist that the user never knows about, a profiler, a learning mode, or somesuch.

LM

TY kindly for your reply. For my next update I am pointing out after running the profiler and adding some apps manually to the safe list, it is all running although I had to start the CAV and CFP manually to get them open and showing, they wont seem to show in the Task Tray for some reason. But, Hopefully they are functioning as they say they are. Both are on and active incl. HIPS and I am able to launch programs perfectly again…so for now…I am Happy. Anyway, Little Mac I was wondering if you have heard of any conflicting software that I can look into replacing, short of giving you a pastebin to my whole slew of installed apps, I dont know what to do, or where to look for apps that have caused grief to others… Thanks again and have a good one…

Kaspersky AV (or the free AOL version) have in the past (version 6, anyway) played very poorly with a number of FWs, including CFP. Only thing I’m really aware of. If you do have any other active AV, that’s just asking for trouble, though.

There is a known issue with Windows (acknowledged by MS, but they don’t know how to fix it/won’t fix it) wherein some systray icons may not show. One user recently reported that installing CFP with AV disabled resolved that problem.

To make sure CAVS and CFP are in fact running (before opening manually), open Task Manager. Check the Processes tab for:

CMain.exe (the GUI)
CavSe.exe (two instances)
CavEmSvr.exe (email scanner)
CavaSM.exe
CPF.exe (the GUI)
CmdAgent.exe (core executable)

LM

Actually on that note all but the CFP were running before manual opening. I have no other AV installed as I have been around enough to know that is just plain impossible and foolhardy to do, as they just fight amongst themselves making EVERYTHING unusable…and Unsafe. Would it be better to try to install the AV first THEN the firewall? I had installed just the AV the third or forth time around but by that point my trouble’s could have propigated so badly that it might not have made a difference…Anyway, This all should be some good reading for others experiencing similar issue’s…Everything seems to be going smooth for now, I’ll keep ya posted…

UPDATE!
ARRRRGGGGGGG!!!. Now I have it all running, and when I goto MANAGE the HIPS list (Because it wouldn’t let me open Winamp, I had to kill Hips and load it then turn Hips back on, BECAUSE…) It just starts to load, and Closes…this is VERY frustrating, I am going to go check with support AGAIN on this issue with the CAVS, it is not likely I’ll get help there though as they have sent me back here as it is a BETA…Is there any OTHER version? Lol, Support and Forum’s would solve so much more, so very much more quickly…I think…

My suggestion would be to do the following (each step completed in SafeMode; reboot in between):

  1. uninstall fw
  2. uninstall av (all aspects)
  3. clean registry of any remnants (you can use a free utility like regseeker or ccleaner if you like); be sure to create a backup before removing any entries.
  4. reinstall fw
  5. reinstall av
  6. reboot normally, allow profiler to run

Then see if you’re still having the same issues.

LM

Done that many times, in normal start-up, clean start-up, and safe mode, the last few times the profiler wouldn’t even run and I use CCleaner, and Registry Bot, Noeither found orphaned or invalid keys. TY though, any other suggestions?

I hate to say no, but I really don’t have any others at the moment. Yours is an odd one as you have at least one other system it apparently works fine on. Are all your hardware/software drivers up to date? Do you have any system-monitoring/performance utilities that always run?

Reasons: Lots of time drivers (especially video, nic) seem like they can cause problems for some reason. With a previous release of CAVS, alcohol 120% caused problems. That has since been resolved, and I’m not immediately aware of other issues, but you never know… Looking for always-on utilities might be useful (if you have any).

LM

Try disabling HIPS Application Control right after windows start, before opening any applications.

Also see: https://forums.comodo.com/cavs_beta_corner/cavs_hips_application_control_crushes_windows_explorer-t14529.0.html