CAV003 error

Hi, first of want to thank COMODO Group with coming up with their line of essential products for free.
I have installed CAV & CPF on many computers and so far everything was fine.

Few days ago I installed both of them on a PIII 1Ghz 512MB RAM computer running Windows 2000.
After updating CAV and rebooting, the computer slowed down drastically…I mean I had to wait up to 20 mins for a window to open after double-clicking an icon. There was no way for me to uninstall it in "Normal " mode and I couldn’t do so in “Safe” neither. (it was only later I found out how to remove it in “Safe” mode by browsing this forum)
Basically I deleted the whole Comodo folder in “Safe” mode then rebooted, it prompted me to install something which I canceled. Went to Add/Remove removed CPF, rebooted, strangely CAV wasn’t in my Add/Remove. Then Comodo website, downloaded CPF, installed, rebooted…everything till this point was fine. Downloaded CAV, installed, rebooted at login i was prompted “Cav003…On access scanner failed to start”. Failed to start it manually, tried to starting “cavasm.exe” through “run” … same thing. Tried to uninstall and reinstall CAV…same error
I read a lot of topics in this forum regarding this error but they’re either weren’t solved or the solution doesn’t work for me.
Any suggestions will be welcome…thanks

Just an update:
After posting here and giving a couple of days with no result, I decided to install the latest Beta version of CAVS and i got rid if this error. But if anyone has an idea to why it happened I would like to know.

I had almost the exact same issue, (was installing W2K on a new machine and installed the other products as well). The fix was that CAV needs service pack 4. After downloading and installing service pack 4 (while hitting ‘cancel’ each time I rebooted to the CAV installer), it was able to install correctly. However - everything seems to be fine exept on startup (and afterwards) the ‘On Access Scanner’ doesn’t start and when I try to start it manually, it fails with the ‘CAV003’ error message. I’m afraid I might have deleted a .dll file that wasn’t re-installed.

Any ideas Comodo? Thanks for any help.

Might be worth your while uninstalling CAVS and re-installing. Try using the free trial of this to do the uninstall:

I recommend the latest CAVS beta for your new installation - it is a massive improvement on version 1.1.


Hi, I installed CAV 2.0.8 Beta some hours ago and got the same problem. Everytime when CAV loads or when i try to load the on-access scanner, i get the “Cav003…On access scanner failed to start” message. My system is P4 3 GHz, Geforce FX 5950 Ultra, Windows XP Pro SP2. I hope someone has got a solution for this problem for me as i want to try the antivirus.

Thank you for your help.

I’ve only had this problem when I set the Comodo AntiVirus & AntiSpyware Service to start on Manual rather than Automatic.

I did that because it was causing problems with locking everything up after Windows login. But then, the On-Access failed, with the 003 error.

I resolved the issue by using a free startup controller application (in this case, StartRight) to move CAVS to the end of the order. With the Service on Automatic, CAVS loads fine, nothing is locking up, and the on-access scanner is active.

I don’t know if that may help you, but that’s what I’ve got…