CAV v5.9.x update problems

This current problem began post v5.8 update; its been working fine v5.8.x for a while now; I’ve been happy. Oh, sure, the occassional “update failed” but retry eventually has always worked. Its worked SO well that 11 Oct 17 AV defs v10450 was the last full AV defs .Z file I had.

Since I allowed CIS to update itself to v5.9.x I can NOT get v5.9.x to update AV definitions automatically. I’ve gone through the update dance so many times I could puke. The following is what I KNOW works:

I went offline and completely uninstalled CIS - manually deleted the vestiginal CIS folders & ran CCleaner v3.14.1616 - and installed CIS v5.5.19586.1383. I then went into MSCONFIG & disabled ANYTHING that was 3rd party non-Windows default app. I rebooted - offline - and then loaded the LAST version of CFGX I had archived for v5.5.x. Then I rebooted into safe mode & deleted the existing AV def files, and extracted CIS v5.5.8 AV def v10450 using the latest version of WinRar.

After rebooting CIS showed that AV def v10450 was the active AV def file. Obiously CIS indicated that AV defs were out of date (status: never updated).

I went on-line and did a CIS update. It checked said there was an update, spun its gears for about TWO seconds and asked to reboot. I reboot.

Then I check the CIS AV def version: v10450. I check for CIS update: version update available. I implement the update.

I reboot and check the CIS version: CIS v 5.9.x, and AV defs v10450 (what is in “repair” is the origina 9k file). I click the update AV button on the “Summary” page, and it goes through its gyrations and tells me that the update failed (I check the status and AV def is v10450). I try it again and again it fails. Now I try that again and it tells me that AV ENGINE NOT INITIALIZED. Rebooting doesn’t resolve the issue. The AV file in “repair” & “scanners” is the SAME file.

CIS AV will not properly intialize - v0 - and EVERYTHING is going wonky on me, i.e., NOTHING trusted is recognized.

I perform clean re-install to v5.5.x (per the aforementioned), and then extract the CIS AV v10450 again. Once CIS is up using v5.5 CFGX & AV defs, I downloaded the latest version of CIS AV 5.9.x. The first version was v11205 and it was corrupt on extraction.

I was FINALLY able to download a CIS AV v11236 .Z file that wasn’t corrupt on extraction. I can extract the contents of either it, or the v10450 with impunity.

SOMEHOW, the AV files offered by Comodo are corrupt. IF the problem was the download was corrupt, then WinRar would NOT open the file.

IF the problem was with respect to my memory sub-system, either RAM or motherboard, e.g., CPU-DRAM interface (among other issues plausible), the problem should be duplicable with either v10450 or v11236; they ARE not. I can open and extract the contents of either file without problem each and EVERY single time.

Here’s another clue: when I have a “working” version of any arbitrary CIS AV def file, and I update, the CIS AV update fails to v0, the SAME file is in both repair & in scanners. I’ve established that I can “move” CIS AV v11236 from “scanners” to “repair” and after extracting the latest version of CIS AV (or auto-update, take your pick), CIS will on reboot revert to v11236.

My system copying the files from “repair” to “scanner” is not causing corruption. Why should I consider that the copy operation from “scanner” to “repair” is corrupting the files?

Moreover, when I start with v10450 (a v5.5.x CIS AV def file) - it existing in both “repair” & “scanner” folders, when I extract v11205 or whatever other ■■■■ Comodo has offered - aside from v11236 - the system recovers nicely back to either v10450 or v11236. And it does that with impugnity.

To sum up: I can NOT get v5.9.219863.2196 to update AV defs for want of God’s wrath upon the MOST wicked.

Please try the procedure as described in Where can i download the latest full AV database? and report back.