CAV is default in every context menu ?!

Since I installed the newest CAV Beta 2.0, the item “Scan with Comodo AntiVirus” is default in every context menu ?! So when I double click a file (program executable, JPG etc) it does not open the default application. I see no option in CAV to change this behaviour. I also tried to change the shell extension behaviour in Windows options, but “Scan with Comodo AntiVirus” remains the default … Any suggestions ?

I have the CAVS 2.0x Beta, but the program to open jpg files is Windows Picture and Fax Viewer, and at menu context is marked as bold the Scan with Comodo AntiVirus, so when i did this action, shows the message in below (You may not have sufficient privileges to Disinfect and Quarantine all infected files).

http://img75.imageshack.us/img75/6205/24007636cd3.jpg

To solve your problem, perhaps you can try to install the www.irfanview.com and preset the images file format as default for this program.

[attachment deleted by admin]

TissaTussa, welcome to the forums.

I’ve seen in my own context menu that “Scan with Comodo AntiVirus” appears with bold style, but nevertheless it hasn’t changed any default application to open files with.

Is it possible to right-click, chose “Open with…” and then chose your dedicated program? Also tick “Always use the selected program to open this kind of file” then. Quite boring to re-dedicate every type of file I guess, but I’m afraid I have no other idea right now. Also, I’m not sure how you would run an exe-file. Open… with what?

/LA

Hello all,

I fixed it! However, it was not easy. First, let me answer the post of LeoniAquila :

Mmm … strange, I thought the bold item is the one that’s done at double click … most of the time at top of the context menu.

You’re right, there’s no “program” associated with an .exe … so this has to be something else …The suggestion you made is known to me : that’s what I meant by “change the shell extension behaviour in Windows options”. Didn’t help.

First I tried to reinstall CAV in SafeMode … did not help. Then I tried to find an application that let me change the associations or shell/context menu entries or even lock them while installing an application and I found “Associate This” at http://www.spearit.com … did not help either. At last I editted the registry (sure, after backup) and exported and then removed the following entries …

[HKEY_CLASSES_ROOT*\shellex\ContextMenuHandlers\Comodo AntiVirus]
@=“{4255A182-CAD9-4214-A19B-7BA7FB633BBD}”

[HKEY_CLASSES_ROOT\file\ShellEx\ContextMenuHandlers\Comodo AntiVirus]
@=“{4255A182-CAD9-4214-A19B-7BA7FB633BBD}”

[HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\Comodo AntiVirus]
@=“{4255A182-CAD9-4214-A19B-7BA7FB633BBD}”

… and the problem is solved : the item “Scan with Comodo AntiVirus” is no longer default in every context menu, in fact, it’s not there at all now. Never mind, CAV is working on the background.

Hope you programmer guys find out what it was, and do a bugfix. Maybe I can restore one of these exported 3 regs. BTW. I run Windows XP SP2 Dutch (but not with the very latest MS patches).

Great to hear that you solved this problem. Let’s hope that this bug won’t appear in the next version, 3.0, which may be here before the end of 2007.

/LA