CAV doesn't honour %ALLUSERSPROFILE%

Hi there, firstly having switched from McAfee I just wanted to say what a great product.

With my installation of Windows XP I like to use two partitions, C: for the operating system and D: for Documents and Settings. I’ve noticed that after installing CAV a series of new directories have been created on the C: partition:

C:\DOCUMENTS AND SETTINGS
└───All Users
└───Application Data
├───comodo
│ └───Comodo AntiVirus
│ └───TroubleShootLog
│ cavasm.log
│ cavasm.old
│ CavAud.log
│ monln.log

Looks like %ALLUSERSPROFILE% (D:\Documents and Settings\All Users) is not referenced during the install.

Cheers
Jim

Here’s the version info about my installation,

Comodo AntiVirus - Version Information Report

Product Information
======= ===========
Build Version : 2.0.14.50
DataBase Version : 2.0.0.235
AllowDB Version : 2.0.15.51
Program Updates Version : 2.0.15.51

License Information
======= ===========
License Status : Activated
Product Installation Date: 20-Jul-2007
Product Activation Date : 20-Jul-2007

Program Files Information
======= ===== ===========
CMain.exe : 2.0.12.42
CavApp.exe : 2.0.11.39
CavSn.exe : 2.0.11.41
CavAud.exe : 2.0.9.26
CavMud.exe : 2.0.9.26
Cavasm.exe : 2.0.1.8
CavEmSrv.exe : 2.0.11.40
CAVSubmit.exe : 2.0.11.49
cavengine.dll : 2.0.0.5

Operating System Information
========= ====== ===========
Operating System : Windows XP
Operating System Version : 05.01.2600
Service Pack : Service Pack 2
Internet Explorer Version : 6.0.2900.2180

Hardware Information
======== ===========
Central Processing Unit (CPU) : Unknown P6 family
Available Memory : 1568MB
Total Memory : 2047MB