Can't upgrade to V3.0 - Can a ghost firewall still be installed?

Dear wise people,

Around a year ago I had a free trial of Agnitum Outpost Firewall Pro.
It was OK but later I uninstalled it (or so I thought) and installed Comodo V2.4 instead.
Still later, the computer suffered a major crash, though it has been (mostly) fine since then.
Recently I tried to upgrade to V3.0 but that was when the fireworks really started!
At first it seemed to send the machine crazy, so I unistalled and reverted to V2.4 out of fright.
At the second attempt to install (32 bit version) the computer failed to boot up at all.
The computer is XP and only about 2 years old.

I began to suspect that more than one version of Comodo might be running,
So switched to ‘Allow All’ and checked the security centre for signs of a running firewall
To my amazement it said ‘Outpost Firewall Pro is ON’.
Tried regedit and Registry Helper + removed a couple of obvious references to the said firewall but to no avail.
Tried CCleaner and Registry Helper again but this time found no reference to Agnitum or Outpost
So, is Outpost, or some ghostly remnant of it, still lurking inside the box?
Or is Windows just acting dumb?

Any thoughts?

Thanks a lot

Charioteer-welcome to the forum. I pick the last one - Windows acting dumb.

** FAQs/Threads - Read Me First **:

[b]Windows (Security Centre) Doesn't Recognize Comodo Firewall[/b],2479.0.html

Just in case there are some remnant registry keys from your previous installation(s) of CFP, check this thread:

I’m also a former Outpost Firewall Pro user, and I can attest that it took awhile to completely remove all traces of Outpost from my system prior to installing CFP for the first time on my old desktop system (see my signature below for details).

Thanks Guys,

Tried the above and located nothing to remove from previous firewalls (either Comodo or Outpost).
Tried installing v3 again but still can’t get it to run properly on my computer.
Again the computer just would not reboot after installing without using system restore.
Whilst v3 was still ‘in the system’ following the restore it give error messages would not run properly.
So have reinstalled v2.4 for now.
That works fine.
Odd, isn’t it!


Try this tutorial on how to completely uninstall Outpost firewall: .